Linux CLI globalprotect connect. Error: No Network Connectivity

Reply
Highlighted
L0 Member

Linux CLI globalprotect connect. Error: No Network Connectivity

I am trying to connect to my university's VPN. I have installed the CLI version of globalprotect on my laptop running Arch Linux. The university pointed me to a location to download a tarball with 5.1.1.0-17 debian packages. I believe I have successfully installed fine (although a reboot was needed).

I receive the following error when I try to use the CLI to connect via (note username and institution redacted to protect the innocent):
>> globalprotect connect --portal vpn.<MyInstitution> --username <MyInstitutionUsername>

Retrieving configuration...                                             
Retrieving configuration...                                             
Failed to connect to vpn.<MyInstitution>.
Error: No Network Connectivity. Please verify your network connection and try again.

 

 

 

For what I can tell the gpd service appears to be up and running fine:

>> sudo systemctl status gpd                     
● gpd.service - GlobalProtect VPN client daemon
    Loaded: loaded (/usr/lib/systemd/system/gpd.service; enabled; vendor preset: disabled)
    Active: active (running) since Tue 2020-08-25 08:31:43 EDT; 40min ago
   Process: 74461 ExecStartPre=/opt/paloaltonetworks/globalprotect/pre_exec_gps.sh (code=exited, status=0/SUCCESS)
  Main PID: 74463 (PanGPS)
     Tasks: 13 (limit: 38064)
    Memory: 22.7M
    CGroup: /system.slice/gpd.service
            └─74463 /opt/paloaltonetworks/globalprotect/PanGPS

Aug 25 08:31:43 plato systemd[1]: Starting GlobalProtect VPN client daemon...
Aug 25 08:31:43 plato pre_exec_gps.sh[74461]: no pid file
Aug 25 08:31:43 plato systemd[1]: Started GlobalProtect VPN client daemon.

 

>> ps -fe | grep Pan
root       74463       1  0 08:31 ?        00:00:00 /opt/paloaltonetworks/globalprotect/PanGPS
<user>   74481       1  0 08:31 ?        00:00:00 /opt/paloaltonetworks/globalprotect/PanGPA start

 

 

 

Also I have plugged https://vpn.<MyInstitution> into a web browser to confirm that I can see my university's portal, which appears to work fine. I have tried reinstalling and restarting a couple of times, and I have tried globalprotect collect-log to see if I can see anything funky in the logs. I have also thoroughly read through the GlobalProtect User Guide PDF Linux sections.* Unfortunately I am at a loss of what to try next. Can any kind person offer some suggestions?!

 

* I have also tried to install the GUI version in Linux but seem to be held up by a missing dependency: libqt5webkit5. I found a qt5-webkit in Arch Extra, but that didn't fix the dependency issue.

Highlighted
L1 Bithead

Hey @RyanBF,

 

As the Arch distro isn't listed in the compatible versions list, we can't confirm full functionality of the GlobalProtect App.

 

I've included a link below that lists all compatible versions for each specific App release:

 

https://docs.paloaltonetworks.com/compatibility-matrix/globalprotect/where-can-i-install-the-globalp...

 

 

-Cheers
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!