minemeld-web FATAL, CENTOS Latest Dev Edition

L0 Member

minemeld-web FATAL, CENTOS Latest Dev Edition

I performed a recent git pull and performed the standard upgrade due to we were having issues on the edition we were on. However the minemeld-web will not load. I tried the revert back to pip 9.0.3 command for others having the with no luck.

When trying to install minemeld stable it won't install at all so I continued with dev (as that is what we had before). I checked the /opt/minemeld/log/minemeld-web.log and I see the following:


[2019-05-20 10:13:21 +0000] [11413] [INFO] Starting gunicorn 19.5.0
[2019-05-20 10:13:21 +0000] [11413] [INFO] Listening at: (11413)
[2019-05-20 10:13:21 +0000] [11413] [INFO] Using worker: gevent
[2019-05-20 10:13:21 +0000] [11417] [INFO] Booting worker with pid: 11417
[2019-05-20 10:13:21 CDT] [11417] [INFO] MMLogger started
/opt/minemeld/engine/core/minemeld/flask/aaa.py:21: ExtDeprecationWarning: Importing flask.ext.login is deprecated, use flask_login instead.
  import flask.ext.login
[2019-05-20 10:13:21 CDT] [11417] [INFO] Config loaded: {'MINEMELD_LOCAL_LIBRARY_PATH': '/opt/minemeld/local/library', 'USERS_DB': 'wsgi.htpasswd', 'MINEMELD_LOCAL
_PROTOTYPE_PATH': '/opt/minemeld/local/prototypes', 'SUPERVISOR_URL': 'unix:///var/run/minemeld/minemeld.sock', 'MINEMELD_PROTOTYPE_PATH': '/opt/minemeld/local/pro
totypes:/opt/minemeld/prototypes/current', 'MINEMELD_PIP_PATH': '/opt/minemeld/engine/current/bin/pip', 'MINEMELD_TRACED_PURGE_PATH': '/opt/minemeld/engine/current
/bin/mm-traced-purge', 'API_AUTH_ENABLED': True, 'MINEMELD_LOG_DIRECTORY_PATH': '/opt/minemeld/log', 'MINEMELD_7Z_PATH': '/usr/bin/7z', 'MINEMELD_RESTORE_PATH': '/
opt/minemeld/engine/current/bin/mm-restore', 'MINEMELD_LOCAL_PATH': '/opt/minemeld/local', 'MINEMELD_GIT_PATH': '/usr/bin/git', 'SNS_ENABLED': True}
[2019-05-20 10:13:21 CDT] [11417] [INFO] USERS_DB loaded from /opt/minemeld/local/config/api/wsgi.htpasswd
[2019-05-20 10:13:21 CDT] [11417] [INFO] FEEDS_USERS_DB loaded from /opt/minemeld/local/config/api/feeds.htpasswd
[2019-05-20 10:13:21 CDT] [11417] [DEBUG] Instance uuid = 676ae5b13fc74631976e1f673fe55b45
[2019-05-20 10:13:21 +0000] [11417] [ERROR] Exception in worker process
Traceback (most recent call last):
  File "/opt/minemeld/engine/current/lib/python2.7/site-packages/gunicorn/arbiter.py", line 517, in spawn_worker
  File "/opt/minemeld/engine/current/lib/python2.7/site-packages/gunicorn/workers/ggevent.py", line 190, in init_process
    super(GeventWorker, self).init_process()
  File "/opt/minemeld/engine/current/lib/python2.7/site-packages/gunicorn/workers/base.py", line 122, in init_process
  File "/opt/minemeld/engine/current/lib/python2.7/site-packages/gunicorn/workers/base.py", line 132, in load_wsgi
  File "/opt/minemeld/engine/current/lib/python2.7/site-packages/gunicorn/app/base.py", line 67, in wsgi
    self.callable = self.load()
  File "/opt/minemeld/engine/current/lib/python2.7/site-packages/gunicorn/app/wsgiapp.py", line 65, in load
    return self.load_wsgiapp()
  File "/opt/minemeld/engine/current/lib/python2.7/site-packages/gunicorn/app/wsgiapp.py", line 52, in load_wsgiapp
    return util.import_app(self.app_uri)
  File "/opt/minemeld/engine/current/lib/python2.7/site-packages/gunicorn/util.py", line 357, in import_app
  File "/opt/minemeld/engine/core/minemeld/flask/main.py", line 3, in <module>
    app = create_app()
  File "/opt/minemeld/engine/core/minemeld/flask/__init__.py", line 70, in create_app
    from . import configdataapi  # noqa
  File "/opt/minemeld/engine/core/minemeld/flask/configdataapi.py", line 18, in <module>
    import sqlite3
  File "/usr/local/lib/python2.7/sqlite3/__init__.py", line 24, in <module>
    from dbapi2 import *
  File "/usr/local/lib/python2.7/sqlite3/dbapi2.py", line 28, in <module>
    from _sqlite3 import *
ImportError: No module named _sqlite3
[2019-05-20 10:13:21 +0000] [11417] [INFO] Worker exiting (pid: 11417)
[2019-05-20 10:13:21 +0000] [11413] [INFO] Shutting down: Master
[2019-05-20 10:13:21 +0000] [11413] [INFO] Reason: Worker failed to boot.


Any suggestion how to resolve this issue? This worked before the upgrade. I had to upgrade due to the engine was rebooting over and over and over and I had to reboot the server once a week to resolve the issue.

Thanks much for the help.

Accepted Solutions
L0 Member

Nevermind - Self resolved issue:

sudo cp /usr/lib64/python2.7/lib-dynload/_sqlite3.so /usr/local/lib/python2.7/sqlite3/

View solution in original post

All Replies
L0 Member

Nevermind - Self resolved issue:

sudo cp /usr/lib64/python2.7/lib-dynload/_sqlite3.so /usr/local/lib/python2.7/sqlite3/

View solution in original post

L1 Bithead

Ran into same issue on Centos 7, but symlinked file to same location in /usr/local/lib/ instead of copying.


sudo ln -s /usr/lib64/python2.7/lib-dynload/_sqlite3.so /usr/local/lib/python2.7/lib-dynload/


Thanks for the info.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!