Problems with CentOs 7 and MM 0.9.52

Showing results for 
Search instead for 
Did you mean: 

Problems with CentOs 7 and MM 0.9.52

L4 Transporter


Hi guys,


I used to run standalone MM 0.9.50 with CentOS 7, perfectly. Last week I updated MM to 0.9.52 with the help of @lmori and the proccess was completed with success. See ( ).


However since the upload my MM doesn't work the same way. On my Dashboard is visible that my miner works fine, more than 90K indicators, but almost none of them ara available, less than 1K in the outputs (see figure below).




If we detailed the proccess, we see that the status of many nodes is "stopped". The number of indicators forwarded by the miners is high.





The number of indicators forwarded by the aggregators is almost the same.




But the number of indicators available by the outputs is extrmely low.




Has anybody experienced something similar? How you dealed with the problem?


Best Regards.


Hi @lmori 


I'm having some issues with the upload of MM to 0.9.52, as reported previously. After the preocedure you told me to follow to rool back to 0.9.50, my machine has not worked properly. First of all, it still shows I'm using the 0.9.52 version, as I showed in my last post.


I tried to repeat the procedure and now I get an error


MM AnsibleMM Ansible



Could you tell me what is the best pratice to get my MM back to work? Is is really affecting (downgrading) my experience with MM.


Best regards.

Hi @danilo.souza,

something is wrong in the downloaded code, it seems to be pretty old.


Please do this:

  • remove your current minemeld-ansible directory and /opt/minemeld/engine, /opt/minemeld/www and /opt/minemeld/prototypes directories
  • copy /opt/minemeld/local contents somewhere for backup
  • update your CentOS 7 packages to the latest versions (yum update)
  • follow the instructions here:

The new version of the playbook will install the MineMeld version that is still in beta but is way more reliable on CentOS7.



L2 Linker

Tried but all I get is this.


TASK [minemeld : minemeld-node-prototypes repo] *********************************************************************************************************************************************************************************************
ok: []

TASK [minemeld : minemeld-node-prototypes current link] *************************************************************************************************************************************************************************************
ok: []

TASK [minemeld : minemeld-core repo] ********************************************************************************************************************************************************************************************************
fatal: []: FAILED! => {"before": "bdd6879cc2c72094702d301e3e1bae4a198eed5f", "changed": false, "msg": "Local modifications exist in repository (force=no)."}
to retry, use: --limit @/opt/minemeld-ansible/local.retry

PLAY RECAP ********************************************************************************************************************************************************************************************************************************** : ok=31 changed=0 unreachable=0 failed=1

Hi @StephenBradley,

did you delete the directory /opt/minemeld/prototypes before rerunning the playbook?




Well it seemed to have gotten farther but now I get a firewall not running error.

Hi @StephenBradley,

could you elaborate? What error do you see?

TASK [minemeld : collectd types] ************************************************************************************************************************************************************************************************************
ok: []

TASK [minemeld : open https port] ***********************************************************************************************************************************************************************************************************
fatal: []: FAILED! => {"changed": true, "cmd": ["firewall-cmd", "--zone=public", "--add-service=https"], "delta": "0:00:00.396078", "end": "2019-03-01 08:33:12.260520", "msg": "non-zero return code", "rc": 252, "start": "2019-03-01 08:33:11.864442", "stderr": "FirewallD is not running", "stderr_lines": ["FirewallD is not running"], "stdout": "", "stdout_lines": []}

RUNNING HANDLER [minemeld : restart redis] **************************************************************************************************************************************************************************************************
to retry, use: --limit @/opt/minemeld-ansible/local.retry

PLAY RECAP ********************************************************************************************************************************************************************************************************************************** : ok=75 changed=36 unreachable=0 failed=1

Hi @lmori 


I followed the steps you indicated but I'm still getting an error:




Have you ever experienced something similar?



Did you delete the directory /opt/minemeld/prototypes before rerunning the playbook like Luigi (lmori) suggested?  That fixed my problem I was having with that issue.



Hi @StephenBradley 


for sure. When updating I delete 






Unhapply it did not work for me.


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!