Problems with CentOs 7 and MM 0.9.52

L4 Transporter

Hi @lmori 


I'm having some issues with the upload of MM to 0.9.52, as reported previously. After the preocedure you told me to follow to rool back to 0.9.50, my machine has not worked properly. First of all, it still shows I'm using the 0.9.52 version, as I showed in my last post.


I tried to repeat the procedure and now I get an error


MM AnsibleMM Ansible



Could you tell me what is the best pratice to get my MM back to work? Is is really affecting (downgrading) my experience with MM.


Best regards.

L7 Applicator

Hi @danilo.souza,

something is wrong in the downloaded code, it seems to be pretty old.


Please do this:

  • remove your current minemeld-ansible directory and /opt/minemeld/engine, /opt/minemeld/www and /opt/minemeld/prototypes directories
  • copy /opt/minemeld/local contents somewhere for backup
  • update your CentOS 7 packages to the latest versions (yum update)
  • follow the instructions here:

The new version of the playbook will install the MineMeld version that is still in beta but is way more reliable on CentOS7.



L2 Linker

Tried but all I get is this.


TASK [minemeld : minemeld-node-prototypes repo] *********************************************************************************************************************************************************************************************
ok: []

TASK [minemeld : minemeld-node-prototypes current link] *************************************************************************************************************************************************************************************
ok: []

TASK [minemeld : minemeld-core repo] ********************************************************************************************************************************************************************************************************
fatal: []: FAILED! => {"before": "bdd6879cc2c72094702d301e3e1bae4a198eed5f", "changed": false, "msg": "Local modifications exist in repository (force=no)."}
to retry, use: --limit @/opt/minemeld-ansible/local.retry

PLAY RECAP ********************************************************************************************************************************************************************************************************************************** : ok=31 changed=0 unreachable=0 failed=1

L7 Applicator

Hi @StephenBradley,

did you delete the directory /opt/minemeld/prototypes before rerunning the playbook?




L2 Linker

Well it seemed to have gotten farther but now I get a firewall not running error.

L7 Applicator

Hi @StephenBradley,

could you elaborate? What error do you see?

L2 Linker

TASK [minemeld : collectd types] ************************************************************************************************************************************************************************************************************
ok: []

TASK [minemeld : open https port] ***********************************************************************************************************************************************************************************************************
fatal: []: FAILED! => {"changed": true, "cmd": ["firewall-cmd", "--zone=public", "--add-service=https"], "delta": "0:00:00.396078", "end": "2019-03-01 08:33:12.260520", "msg": "non-zero return code", "rc": 252, "start": "2019-03-01 08:33:11.864442", "stderr": "FirewallD is not running", "stderr_lines": ["FirewallD is not running"], "stdout": "", "stdout_lines": []}

RUNNING HANDLER [minemeld : restart redis] **************************************************************************************************************************************************************************************************
to retry, use: --limit @/opt/minemeld-ansible/local.retry

PLAY RECAP ********************************************************************************************************************************************************************************************************************************** : ok=75 changed=36 unreachable=0 failed=1

L4 Transporter

Hi @lmori 


I followed the steps you indicated but I'm still getting an error:




Have you ever experienced something similar?



L2 Linker

Did you delete the directory /opt/minemeld/prototypes before rerunning the playbook like Luigi (lmori) suggested?  That fixed my problem I was having with that issue.



L4 Transporter

Hi @StephenBradley 


for sure. When updating I delete 






Unhapply it did not work for me.


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!