Unable to connect to TAXII server when message bindings 1.1 and 1.0 are present


Changes to the LIVEcommunity experience are coming soon... Here's what you need to know.

L1 Bithead

Unable to connect to TAXII server when message bindings 1.1 and 1.0 are present

Hi to all,

i've been trying to set up a TAXII client (miner node) in Minemeld but i'm having the same error of #221(that has not solutions):

"nodename" - "collectionname" collection does not support TAXII 1.1 message binding (DATA_FEED).


Through the discovery service i saw that the poll service accepts both message bindings 1.1 and 1.0. Not knowing the exact syntax to set up the message bindings inside the prototype, I tried several times:

  • message_binding: urn:taxii.mitre.org:message:xml:1.1
  • message_binding: ["urn:taxii.mitre.org:message:xml:1.0", "urn:taxii.mitre.org:message:xml:1.1"]
  • binding: urn:taxii.mitre.org:message:xml:1.1
  • message_binding: 1.1

I already set up another two TAXII clients and they worked well (the only difference is that the poll service has just 1.1 message binding)


Minimeld VERSION is 0.9.46.


If you need other information please don't esitate to ask me :)

Thank you in advance.


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!