Who Me Too'd this topic

Who Me Too'd this topic

L0 Member

TRAPS - Mac OS X High Sierra (10.13)

What is the ETA for Traps to be compatible with High Sierra?  We're fighting a Mac population whose users want to move to the latest greatest OS for them, but we don't have the protection...

Who Me Too'd this topic