Problem with API Output Manager

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem with API Output Manager

L1 Bithead

Hi

 

Version: 1.2.36

 

I have an issue when I try to select [Step 2] Send API Requests from Export - API Output Manager

 

[Step 1] Generate API Requests completes correctly and populates.   Once I select a setting I have changed and wish to push back to the Panorama I have loaded in the project I get this screen:

 

API_GUI_Issue.PNG  

 

I cannot then select option to Send as it does not appear on the GUI.  I have tried this a few times in three different browsers (Firefox, Chrome and Edge) and it loads the same way each time.

 

Anyone any idea how I can resolve and proceed with an API push? 

 

5 REPLIES 5

L6 Presenter

@Liam_Wynne This could be due to you zoom in the browser, can you please try make the display smaller by going to "view"-> try to zoom out the browser , if it still not working, you can double click on any of the API call, and there is a send button on the right lower corner 

L1 Bithead

Hi Lychiang,

 

Thanks for the response.   It's not an issue with browser zoom - the pop up window as per image in original post zooms in and out as I change settings and remains static.   If the "send button on the right lower corner button" you refer to is the one labelled "[Step 2] Send API Requests from Export - API Output Manager" that is the one I am having issue with. When I click that it pops the screen I have image of above of into the top left corner of the browser window.  The only interaction that can take place with the window is I can click or unclick the box beside label "ne...." (This is abridged start of name of panorama I using in project I working on). I cannot select the window to move it or get it to display any further info in any browser I try this on.   There is no send button to complete the API push.

 

Here is another larger image of how it displays in browser window:

 

API_GUI_Issue2.PNG

 

@Liam_Wynne I mean double click on the API call you want to send , ant it will bring up another window like below screenshot , and select your panorama device , then click on the blue button. 

 

Screen Shot 2022-09-16 at 8.49.45 AM.png

 

 

L1 Bithead

Hi Lychiang,

 

Ok so if I have this screen:

 

API_GUI_Issue3.PNG

 

and I double click that I don't see screen you shared. I get a blank screen like this:

 

API_GUI_Issue4.PNG

I have logged out and back in ; restarted Jobs/Task Manager and stil get same blank screen every time. If I click then on API Output Manager it goes back to original screen with all the fields populated.

 

Also when I go into API Output Manager if I select a specific DG from dropdown where it displays All DG/Vsys it does not populate. Only by removing specific DG  and reverting to All DG/Vsys does the fields (for every DG) get populated.

 

 

@Liam_Wynne Please use google chrome-> select "new incognito window" and try it . I believe your issue is browser related, if you have other machine, you can try https to the expedition from other machine. 

  • 1828 Views
  • 5 replies
  • 0 Likes
  • 76 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!