Question regarding using common argument "execution-timeout" in the python code.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Question regarding using common argument "execution-timeout" in the python code.

L1 Bithead

While running a command in the XSOAR, there is a common argument named "execution-timeout" which increases the timeout for the command. Can I use this argument directly in the python code? 

What I want to achieve is, I have one command which is taking more than 5 minutes (which is the default timeout for a command) to complete. Now, I don't want the user to always add this common argument in the command line while running the command in XSOAR. Is it possible?

1 ACCEPTED SOLUTION

Accepted Solutions

L2 Linker

Hi Shreyash, if this is an automation, you can adjust the timeout in the automation settings.  If it's an integration command, you should be able to set the below server config to increase the timeout for that particular command:

Key

Value

Default

<integration_name>.<command_name>.timeout

Timeout in minutes for specific integration command for brand names (leave the spaces in the name). The command name for fetching incidents would be fetch-incidents.

3

 

 

For reference, please see https://docs-cortex.paloaltonetworks.com/r/Cortex-XSOAR/6.8/Cortex-XSOAR-Administrator-Guide/Install...

View solution in original post

4 REPLIES 4

L2 Linker

Hi Shreyash, if this is an automation, you can adjust the timeout in the automation settings.  If it's an integration command, you should be able to set the below server config to increase the timeout for that particular command:

Key

Value

Default

<integration_name>.<command_name>.timeout

Timeout in minutes for specific integration command for brand names (leave the spaces in the name). The command name for fetching incidents would be fetch-incidents.

3

 

 

For reference, please see https://docs-cortex.paloaltonetworks.com/r/Cortex-XSOAR/6.8/Cortex-XSOAR-Administrator-Guide/Install...

L1 Bithead

@amurret  Much appreciated, but the solution is ineffective. I'm still getting a timeout error. I've included screenshots of server configuration and error messages below.
shreyash_412_0-1674623945965.png

shreyash_412_1-1674624018005.png

 

 

L2 Linker

If the timeout is still showing the old timeout (not the one you configured in the Server config- you probably need to check this in a debug-mode log or set the instance to debug level logs and then view the integration-instance or server.log from the server to see what the actual timeout is for fetch-incidents) then it isn't using the new timeout you set.  Do you have the integration name or the instance name in the server config?  Note that it is the integration name, not instance name, and unless you have a custom integration with the above name in your screenshot you probably have the instance name in your current server config.  Also, are you able to reduce max_fetch and/or first fetch time in the instance config?

@amurret , This is working  <integration_name>.<command_name>.timeout . Can I achieve this using python code?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!