Expedition script fails

cancel
Showing results for 
Search instead for 
Did you mean: 

Expedition script fails

Cyber Elite
Cyber Elite

Hi,

Is this currently a known issue that the expedition 2 initsetup script fails because of unavailable ressources from conversionupdates.paloaltonetworks.com? All the webserver answers is a http 404 error.

It starts with https://conversionupdates.paloaltonetworks.com/ex-repo.gpg where only a 404 error is sent back when the script treis to download this gpg file.

10 REPLIES 10

L5 Sessionator

@vsys_remo , please refer the article here fore the announcement of delay on expedition 2.x release :

https://live.paloaltonetworks.com/t5/expedition-articles/expedition-2-0-release-date-postponed/ta-p/...

 

Hi @lychiang 

I read this. Actually I am talking about the beta init setup script.

Hi all

I am no longer talking about the beta script. I saw that the current stable release also tries to download some of the same files including https://conversionupdates.paloaltonetworks.com/ex-repo.gpg which is not available. So at the moment it is not possible to install the stable or the beta version.

Hi @vsys_remo , The stable release is Expedition 1.x , and it's currently only running on ubuntu 16.04.x , when you run the installation script , please make sure you run it as root and if you have GP enabled, please temporarily disable GP before you run the script.  

Hi @lychiang 

Let me summarize again what I did.

I first set up a new ubuntu 18.04 server where I tried to installe the expedition beta --> installation failed because of missing ressources on conversionupdates.paloaltonetworks.com

Then I installed another server. This time ubuntu 16.04 where I tried to install the stable version-->  installation script fails because of the same reason.

(The servers had internet access and there is no GP involved)

 

@vsys_remo Despite of the error message you encountered, the script should continue to run and finish and when it finished , it will try to start the Agent , and you can try to access the GUI, have you tried that ? 

Hi @lychiang 

This is what I get when I run the beta script on the ubuntu 18.04 server:

 

************************************************************
Installing Expedition packages
************************************************************


Installing Expedition packages

--2021-08-26 23:31:57--  https://conversionupdates.paloaltonetworks.com/ex-repo.gpg
Resolving conversionupdates.paloaltonetworks.com (conversionupdates.paloaltonetworks.com)... 199.167.52.71
Connecting to conversionupdates.paloaltonetworks.com (conversionupdates.paloaltonetworks.com)|199.167.52.71|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2021-08-26 23:31:58 ERROR 404: Not Found.

spawn apt-get install -y --allow-unauthenticated expedition2-beta
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package expedition2-beta
spawn apt-get install -y --allow-unauthenticated expedition2-converter-beta
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package expedition2-converter-beta
chown: cannot access '/var/expedition-converter/': No such file or directory
chown: cannot access '/var/www/html/expedition-api/': No such file or directory

Updating databases

./initSetup2beta.sh: line 253: /var/www/html/expedition-api/database/SQL/pandb.sql: No such file or directory
./initSetup2beta.sh: line 254: /var/www/html/expedition-api/database/SQL/pandbRBAC.sql: No such file or directory
./initSetup2beta.sh: line 255: /var/www/html/expedition-api/database/SQL/BestPractices.sql: No such file or directory
./initSetup2beta.sh: line 256: /var/www/html/expedition-api/database/SQL/RealTimeUpdates.sql: No such file or directory

Tunning some Expedition parameters

cp: cannot stat '/var/www/html/expedition-api/initSetup/apache2/default-ssl.conf': No such file or directory

Installing Spark dependencies

Reading package lists...
Building dependency tree...
Reading state information...
openjdk-8-jre-headless is already the newest version (8u292-b10-0ubuntu1~18.04).
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package expeditionml-dependencies-beta
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1146 (42S02) at line 1: Table 'pandbRBAC.ml_settings' doesn't exist

... and I am not able to access the GUI. There is only an ssl protocol error shown in chrome.

@vsys_remo Please noted Expedition 2.x installation script is not completed developed yet. It will be ready by April,2022 per the article I shared with you earlier. 

Yes, I read the article, that version 2 will be released in 2022 (I know the meaning of the word 'beta' ; )

But I did not assume that not 'completely developed' means not working at all.

And I still think this is a general problem in the repository on conversionupdates.paloaltonetworks.com because - as I also wrote some posts ago - version 1 fails also comoletely --> installation is not possible currently.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!