[IMPORT CHECKPOINT R80.10] Nothing get imported in Expedition

Showing results for 
Show  only  | Search instead for 
Did you mean: 

[IMPORT CHECKPOINT R80.10] Nothing get imported in Expedition

L1 Bithead

Hello all,


I am currently on the 1.1.32 version of Expedition which give me access to the "Import Checkpoint R80.10 (Beta)" feature.

I successfully manage to export the needed package on Checkpoint with the "$MDS_FWDIR/scripts/web_api_show_package.sh -k ... -b" command.


I end up with a .tar.gz with several .json and .html files of the policy package i want to export.

When I untar the files (json + html) and zip them (json + html) into a new file to import it into Expedition, the zip is processed but nothing happens and all the objects fields are empty.

I also tried to get ride of the .html files to only keep the .json files but it's not working either.


Would someone have an idea on this ?


Thank you for your help.


Best Regards,


Sullivan Drouard


L5 Sessionator

Try importing the .tar.gz file that had been generated. The import of the files does not have to be in zip format. 

I already tried to do that but the result is the same.

I should not have issue with the file size because the "upload_max_filesize" and "post_max_size" fields are already set to the right value.


Should the html be present in the package ? I guess we have nothing to touch when we export the package from Checkpoint but since it's not working, i'm wondering ...


Any other idea or maybe some log files that could be helpful for troubleshooting that issue ?







The html files by default are in the exported package and do not cause an issue with the migration of the files. 


Can you post the output from the file:


$tail -f /tmp/error

Ok, great to hear.


Below the result of the $tail -f /tmp/error command :


Warning: implode(): Invalid arguments passed in /var/www/html/libs/common/lib-rules.php on line 4275
Notice: Trying to get property of non-object in /var/www/html/libs/common/lib-rules.php on line 4276
Inserting DNAT affected Rules
Inserting Static-NAT affected Rules
Inserting No-NAT affected Rules
Notice: Trying to get property of non-object in /var/www/html/libs/shared.php on line 7192
Notice: Undefined variable: tagNames in /var/www/html/libs/shared.php on line 7201

I guess some parameters of the Checkpoint configuration can't be processed in the rules.php and shared.php files.

Do you have an idea for importing elements step by step to determine which .json or object is blocking the import process ?


I also tried R80 but my address groups are imported as host with their UID names and Ip address.

If anyone has an idea to solve the R80 part so I can drop the R80.10 part which give less result.

  • 5 replies
  • 76 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!