RE error_SecRulesEnrich No traffic found

cancel
Showing results for 
Search instead for 
Did you mean: 

RE error_SecRulesEnrich No traffic found

L1 Bithead

I have a problem with Rule Enrichment. 

 

The error_SecRulesEnrich gives these messages after analysing the data from a rule which has a lot of data (at least by APP-ID):

  

 

Schermafbeelding 2018-10-29 om 15.36.56.png

I am connected to a firewall, and i can analyse in Expedition the applications (By APP-ID) and getting results.

So i am confused why it sais, no traffic found.

 

MySQL is working, the "expedition internal checks" are all green. 

 

The Rule Enrichment is processing and results in "Completed"

Also i rebooted the VM.

 

1 ACCEPTED SOLUTION

Accepted Solutions

L1 Bithead

Eventually i found the problem.

 

RL and ML does not read the logs directly from the Palo Alto logs, like APPID does. 

 

After exporting an CSV file from the monitoring tab (filtered on the same rule as i want to analyse), and importing this CSV file to the local folder, and changing the security settings on this folder, i got it working.

 

So for Rule Enrichment, there is a need of logging exported from the firewall

View solution in original post

5 REPLIES 5

L7 Applicator

Maybe for that rule there is no log between the time period selected?

I changed the log collector time to several months. No change..

L1 Bithead

Nobody who had this problem, found a solution?

Can you grep your csv file to see of there is any log entry for the rule name you are evaluating?

L1 Bithead

Eventually i found the problem.

 

RL and ML does not read the logs directly from the Palo Alto logs, like APPID does. 

 

After exporting an CSV file from the monitoring tab (filtered on the same rule as i want to analyse), and importing this CSV file to the local folder, and changing the security settings on this folder, i got it working.

 

So for Rule Enrichment, there is a need of logging exported from the firewall

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!