Remote Exception when creating users in Expedition

Announcements

Changes to the LIVEcommunity experience are coming soon... Here's what you need to know.

Reply
Mark_Mills
L0 Member

Remote Exception when creating users in Expedition

I cannot create new users in Expedition v1.1.91.3, and a blank error box stating "Remote Exception" with no other information.   I have tried another installation running an older v1.1.90 and it works fine.

 

When checking the apache error.log file there is the below error and I hope someone can give advice on how to fix this?

 

 

[Thu Mar 04 14:42:54.731320 2021] [:error] [pid 340] [client 10.128.22.14:58607] PHP Fatal error: Uncaught PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'api_key' in 'field list' in /var/www/html/libs/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:77\nStack trace:\n#0 /var/www/html/libs/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(77): PDO->prepare('insert into `us...', Array)\n#1 /var/www/html/libs/vendor/illuminate/database/Connection.php(452): Doctrine\\DBAL\\Driver\\PDOConnection->prepare('insert into `us...')\n#2 /var/www/html/libs/vendor/illuminate/database/Connection.php(657): Illuminate\\Database\\Connection->Illuminate\\Database\\{closure}('insert into `us...', Array)\n#3 /var/www/html/libs/vendor/illuminate/database/Connection.php(624): Illuminate\\Database\\Connection->runQueryCallback('insert into `us...', Array, Object(Closure))\n#4 /var/www/html/libs/vendor/illuminate/database/Connection.php(459): Illuminate\\Database\\Connection->run('insert into `us...', Array, Object(Closure))\n#5 /var/www/html/libs/vendor/illuminate/database/Connection.php(411): I in /var/www/html/libs/vendor/illuminate/database/Connection.php on line 664, referer: 

dgildelaig
L5 Sessionator

I cannot reproduce this error. Actually, this error seems related to a Device creation, and not a user creation

 

What kind of user are you creating?

- Local

- LDAP

- Radius

 

Have you checked if restarting the Expedition instance, the issue persists?

Mark_Mills
L0 Member

Restarting expedition does not solve the problem, this has been tried before.   

 

I get the error when attempting to create both a local user and a ldap user.  

 

Tailing /var/log/apache2/error.log when attempting to create a user generates the error included above every time for some reason.

 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!