Custom Reports takes ages

Announcements

ATTENTION Customers, All Partners and Employees: The Customer Support Portal (CSP) will be undergoing maintenance and unavailable on Saturday, November 7, 2020, from 11 am to 11 pm PST. Please read our blog for more information.

Reply
Highlighted
L4 Transporter

Custom Reports takes ages

Greetings All,

I am presently running PanOS 5.0.4 on a PA-500 HA.  When I try generating a custom report for "URL Log" for a period of 7 days for Top 50 grouped by Top 50 groups with the URL consisting of porn and category not equal to web-advertisements, it takes ages to generate the report i.e. approx. an hour and then when I try to export in either PDF or CSV format, the browser just hangs.

I have tried all the browsers available.  I had this issue initially with PanOS 5.0.0.  Under the impression that the OS was relatively new, I kept upgrading till 5.0.4 but with no luck.

I then restarted the Log Receiver, then the management server for no fun.

Any one else has such problems?  Any ideas or thoughts?

Many Thanks

Kind Regards,

Kalyan


Accepted Solutions
Highlighted
Palo Alto Networks Guru

This is a current feature request, please contact your SE to add your vote.

View solution in original post


All Replies
Highlighted
Palo Alto Networks Guru

I would say schedule the report instead of doing it "Run now".  For there you can either have it emailed or it will just sit on the hard-drive and you can access it the next day for download.  There is more overhead in creating the PDF than the csv or xml, so if you are having problems, try to export in the other formats.  Hope this helps.  Thank you,

~Jamie

Highlighted
L4 Transporter

Would you by chance know why the email scheduler won't send these reports? I have a ticket open with support but they can't seem to figure it out. It's actually been open since early this year. Just trying to reach out and get some ideas.

Highlighted
L4 Transporter

Not really helpful Jamie.

If there is more overhead in creating the PDF then, can you please explain why is it a sweet and simple process for the same report on a different PA-500 running version 4.1.11?  These reports that are being generated on the fly are on purpose as they are requested every now and then.  I can't go back to the Management and say, we will hand it over to you tomorrow, specially when PAN allows us to generate reports on the fly.

And it is not just about PDF, it is the same with CSV and XML!

Cheers

Kalyan

Highlighted
L3 Networker

Version 5.0.x has some performace issues on 500 and 2000 series. If the dataplane has high cpu utilization I suggest the ram upgrade available for 500 devices, .

Also with my 500 devices (4.1.12) sometimes I need to restart them in order to re-gain management plane usability.

Highlighted
Palo Alto Networks Guru

Kalyan,

     I am sorry you did not find the information useful.  I am trying to offer suggestions to help get around the issue.  Another workaround might be, to offer a report of the top 5 URLs by 50 groups for a shorter time period immediately and then offer the top 500 the next day. 

    The reason why it might work on a different PA-500 could be that there is a lot less traffic on it.  There could be many other factors that could lead to one firewall producing the report and another not producing the report.  Or as NGS mentioned, it could be the system is under heavy load and could use a memory upgrade. 

     Overall, I am sorry that you are having this issue, and we are working on how we can improve run now reports.

Thank you,

~Jamie

Highlighted
L3 Networker

Apart from PA-500 specific problem, another operation could be tried in order to quickly  obtain reports.

Exporting the postgress logdb from PA-500 and importing it to a VM-100 (even not licensed) should provide the results your are looking for.

scp export logdb to userabc@1.2.4.3:c/a/b/c

scp import logdb from userabc@1.2.4.3:c/a/b/c

I wanted to try these operations some weeks ago in may labs and now I schedule for the next week.

Highlighted
L2 Linker

Hi, I am experiencing the same issue, on a PA2020 pair, since upgrading to 5.0 (currently at 5.0.4). The reports run fine (I am running a 30 day report on "online-personal-storage") even if it takes a while.

When trying to export (pdf, csv, xml) a new browser page starts, and sits, and sits, then eventually times out. I DID get ONE .pdf file that did export, one time, not sure why that worked...

Scheduling the report has the same issue also, the reports do not get emailed, pulling up the reports also cannot export them to any format.

I currently have 3 reports needing to be generated and distributed, clients are waiting....

Update: The Email scheduling and Scheduled reports had been cleared on the appliance, so this portion is unknown for me at this time. I have set this up to run and email, so should have another status tomorrow.

One report for the above shows for April 30th, this report cannot be exported using any format.

Message was edited by: Russel Smith (Clarifying Scheduling status)

Highlighted
L2 Linker

The scheduled report came through email, (PDF), but still cannot download the created report from the device.

Any way to have the scheduled report send in .CSV format?

Highlighted
Palo Alto Networks Guru

This is a current feature request, please contact your SE to add your vote.

View solution in original post

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!