GlobalProtect 5.0.2 install/update issues

Reply
Highlighted
L0 Member

GlobalProtect 5.0.2 install/update issues

Had an update prompt on an existing/working version of GlobalProtect that failed. Could not start or reconfigure installation. Removed the old version manually and tried to install 5.0.2, when I received a message "There is a problem... A program required for this install to complete could not be run." I tried updating the C++ framework I saw elsewhere but now I'm stuck. Any ideas?

Tags (1)
Highlighted
Cyber Elite

Re: GlobalProtect 5.0.2 install/update issues

@xingtheli,

When you say that you removed the application manually, did you actually use the uninstaller or not. It's possible that you haven't fully removed the application and one of the update checks are causing the install to run the upgrade script instead of cleanly installing the application; that could lead the application to error out like that. 

You can always output the install logs and see exactly what you can see on the installer. Otherwise, it might be worth attempting to restore point from before you attempted to install the update. 

Highlighted
L0 Member

Re: GlobalProtect 5.0.2 install/update issues

The uninstaller via add/remove programs failed with the same error and I could not find the PAN uninstaller in the install directory, which is why I did so manually via cmd/regedit/etc. Possible that I did't get it all. The Windows log from install was 1603, expected given the error I saw. 

Looks like a log file was also created in the intended install directory:

(T6184) 12/28/19 09:42:32:633 Info (1142): Remove globalprotect logs and cache data.
[P15676] 12/28/19 09:42:32:700 Info ( 998): ####GPC(NA) MSI started with -uninstall
[P15676] 12/28/19 09:42:32:702 Info (1096): uninstall filter driver now
[P15676] 12/28/19 09:42:33:653 Info ( 437): DeleteService starts.
[P15676] 12/28/19 09:42:33:654 Info (1115): Error uninstalling service
[P17772] 12/28/19 09:42:35:675 Info ( 998): ####GPC(NA) MSI started with -rollback

Highlighted
Cyber Elite

Re: GlobalProtect 5.0.2 install/update issues

@xingtheli ,

Ya, sadly there were various issues with the uninstall script, which were hopefully fixed between the last two releases in the 5.0 GlobalProtect releases. I would really recommend reaching out to TAC and having them ensure that you are starting from a clean base; it appears from your installation log that it's still detecting a PAN service installed. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!