Issue with GlobalProtect after Upgrade

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with GlobalProtect after Upgrade

L1 Bithead

Hello,

 

We're currently experiencing some issue with several clients that are trying to upgrade their client.

They're moving from 2.3 to 5.1. Sometimes, the client cannot connect at all (clicking on connect button from gp client but nothing is happening)

I went through multiple documentations and KB and what I found is that the service PanGPS is not there (in app services) so nothing is running on local tcp port 4767. I also checked that there is not any other app that could generate a conflict.

I tried uninstalling the whole app, deleting paloalto folder and folder Palo Alto in registering key app.

What I found is that, even after the removal of global protect, there is still PanGP virtual adapter present in ethernet settings

I tried manually uninstalling this adapter without succeded, it stucks in loading and tried couple times.

 

 

Does someone already experienced that kind of weir behavior ? 

 

Yoann

5 REPLIES 5

Cyber Elite
Cyber Elite

Did you reboot after uninstalling and deleting folder/reg keys?

L1 Bithead

Yes, that is something I tried but as I mentionned, in my opinion this is the virtual adapter that is "blocking". I tried with my own laptop and when we uninstall GP, it removes the virtual adapter with the process.

 

With the faulty client, I was able to uninstall the virtual adapter from windows safe mode and then reinstall again afterall, everything was working as expected.

 

I'm looking for a way to force remove this **bleep** virtual adapter that I cannot remove with "device manager". I don't want to do "windows safe mode" if my user is at home and vpn not up and running.. difficult to remotely recover their laptops.

 

Yoann

Cyber Elite
Cyber Elite

@Yoann-Wolf,

Are you actually talking about GP 2.3 or is that a typo? 2.3 had quite a few bugs to the point that I'm not shocked that it isn't uninstalling properly. GlobalProtect not upgrading versions properly and the service not existing or working properly isn't a new or uncommon occurrence, but usually a full removal and re-install fixes it. Obviously the upgrade from 2.3 to 5.1 wouldn't have ever been tested, so something in that process breaking isn't a huge shock. 

 

When you say that you can't remove the virtual adapter in the device manager without going into safe mode, what error are you actually getting when you attempt to do the uninstall? I recall an issue in the early days of GP that we had to actually remove the virtual adapters registry entry to get it to uninstall properly, and you could possibly be running into that. You can find that under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Sservices\Tcpip\Parameters\Interfaces\

 

L1 Bithead

Hello

 

Thanks for your answer.

Yes, we had a very old release that's why it was urgent to upgrade our clients.

I understand it has never been tested and validated officially but I tried myself in testing environment, couple times without encountering any issue. 

 

In fact, there is not any error. It stucks during uninstalling : after several hours I decided to end process.

I had this behavior on multiple clients. I'll wait for any new feedback and try your suggestion but it sounds like a good one. I didn't want to play with registry in a first time, but I'd prefer this solution instead of fixing by a safe mode.

 

Really appreciate your help,

 

Yoann

Hi @Yoann-Wolf 


Couple of months ago we enable transparent upgrade and experiance similar issues (PanGPS service was missing after new version installation) from 5.0 to 51. In 99% of the case manual un-install and manual install did the trick. One of the cases the re-install was failing for unknown for me reason (I don't remember if the interface was still there, probably yes)


After desperat googling around the following did the trick for me:

- Download and run (as admin) https://support.microsoft.com/en-us/topic/fix-problems-that-block-programs-from-being-installed-or-r...
- Choose "Uninstall" and select GlobalProtect from provided list
- Leave the troubleshooter running. It will take some time (5-10+min).
- Once troubleshooter finish run GP installation again

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!