Unable to find interface configured in vm machine in vmware

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to find interface configured in vm machine in vmware

L1 Bithead
I’m new to Palo Alto VM series deployment and it’s the new project .. we’re trying to deploy Palo Alto HA in VMware environment . Deployed ovf template and configured management interface . Connected to GUI and all looks ok . But I’m not able to configure any other data interface because there is no other interface available in Palo Alto . But it’s added in virtual machine with vmxnet3. Show interface all command shows 0 as the number of interface .

Rebooted multiple times didn’t do any good in this case . Any one has clue why this not showing any interface . I don’t think I’m the first one to face this problem . Looking for some urgent help .
6 REPLIES 6

Cyber Elite
Cyber Elite

@Hari007,

Have you since restarted the guest or are you trying to do this with the guest OS running? 

If you’re asking whether I powered off during interface configuration , yes I did power off guest while configuring interfaces . After then restarted twice . No luck

In fact secondary vm was configured with all the required interfaces beforehand I turn on the VM first time . Even that has same issue.

@Hari007

So this can depend greatly on which version of pan-os you're configuring, as some of the settings I'm about to give you haven't been need for a bit. 

1) In the .vmx file verify that all ethernet"X".virtualDev values are set to vmxnet3 instead of e1000. Earlier PAN-OS images defaulted to e1000 instead of vmxnet3 adapters. 

2) The virtual switch attached must be set to Accept the following; again some of this is no longer needed depending on the version. 

- Promiscuous mode

- Mac address changes

- Forged trasmits (Layer2, Virtual Wire, or tap interfaces) 

 

More than likely you're running into #1 and your vmx file isn't actually set to use vmxnet3 interfaces. Depending on the version installed you may also need to hard set MAC addresses on the interfaces; but I'm hoping your using a somewhat newer version. 

 

Thanks for the detailed reply .

Yes I’m using latest version 8.x .

Let me try checking the vmd file entry and change it as you mentioned
I’ve already set promiscuous mode as accept for the port group configured in VDS
Anything else you suggest , because when I had just two interface in VM , I tried editing Vmx file but it was already set to vm net 3 not e1000 .
So then I’ve increases the interface and still no luck

If vmx file is an issue atleast two interface for which I checked the vmxnet3 should’ve come up

Any suggestion guys

It was found to be an issue with Vmx file entry which i have changed and fixed the issue..

 

Thanks for the support guys. 

  • 4392 Views
  • 6 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!