Windows Subsystem for Linux 1 Cannot connect to local gpd service.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

Windows Subsystem for Linux 1 Cannot connect to local gpd service.

L0 Member

Hello,

 

I need help getting an issue with GlobalProtect to work on Windows Subsystem for Linux 1 (WSL1). My university is switching to GlobalProtect in the next few months and I need to be able to regularly (daily) connect from off campus to accomplish my work and research.

 

When I install GlobalProtect on the Windows side it shuts off all internet access to WSL1 (can't ping any website). As soon as I turn it off, I get internet connectivity back to WSL1. I understand others have had similar problems with WSL2. I have not seen anything about this though regarding WSL1 specifically or how to resolve it.

 

So instead, I've tried to install GlobalProtect from inside WSL1 and connect from there. I followed the Linux CLI instructions here using GlobalProtect 6.0.4.1. It appears to install correctly? (see below)

 

❯ sudo dpkg -i GlobalProtect_deb-6.0.4.1-28.deb
Selecting previously unselected package globalprotect.
(Reading database ... 74367 files and directories currently installed.)
Preparing to unpack GlobalProtect_deb-6.0.4.1-28.deb ...
Start installing gp...
Unpacking globalprotect (6.0.4-28) ...
Setting up globalprotect (6.0.4-28) ...
Enable gp service...
Starting gp service...
Starting the process of pangps
Start successful
enable ping
logname: no login name
Starting gpa...
start GPA for sudo user USERNAME
Processing triggers for man-db (2.9.1-1) ...

 

And when I check the processes running I see

USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root     28842  0.0  0.0 113260 13872 ?        Sl   20:52   0:00 /opt/paloaltonetworks/globalprotect/PanGPS
USERNAME 28878  0.0  0.0 284516 13428 ?        Sl   20:52   0:00 /opt/paloaltonetworks/globalprotect/PanGPA start

 

But when I try to run any GlobalProtect command I get the following

Cannot connect to local gpd service.

 

Does anyone have any ideas on how to get this working? A few addition things for context

  • I am using Ubuntu 20.04.5 LTS on WSL1
  • GlobalProtect version 6.0.4.1
  • Any solution including upgrading to WSL2 is really not preferred at this time. I have all my research and development environment set up how I like it on WSL1 and I'd like to avoid a big change that will potentially screw up my workflow.
  • We use a different VPN service currently (not GlobalProtect) that has no issues when it runs on Windows (I still get internet connectivity from WSL1 when it is turned on). Hence why this is not a problem historically, but will become one when we switch.

 

 

0 REPLIES 0
  • 150 Views
  • 0 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!