Azure VM Series - Peered VNET traffic does not go outbound

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Azure VM Series - Peered VNET traffic does not go outbound

L0 Member

I have created a VM series in Azure. I could see that the traffic from trusted subnet (from VM1 in the below diagram) is able to go outbound to internet, however traffic from a peered VNET (from VMs in the subnet1 in the peered VNET in the below diagram) shows "incomplete" status in the logs. I have a route table that routes the traffic from the peered VNET (subnet) to the trusted nic. Any additional configuration is needed to get this outbound traffic working?

 

Palo-Arch.png

2 REPLIES 2

L4 Transporter

A return route in the FW virtual router for the peered vnet.

Security rule allowing traffic

NAT if required

Appreciated the quick response. 

By the return route - is it a static route to the peered VNET added to the trusted Virtual Router? Like below:

Peered VNet space (10.2.0.0/24) : Interface Ethernet 1/2 (trusted) -> Next Hop : IP Address Of the Default Gateway of the Trusted Subnet.

Security rule - since this is non prod, we have Allowed All from trusted zone to untrusted zone - anything more specific to peered?

NAT Rule - anything specific for peering?

 

Thanks in advance!

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!