Do PCNSE and PCNSA Cover PAN-OS 9.0?

Community Team Member

Certification | Education | Palo Alto Networks.png

 

Are you preparing for the Palo Alto Networks Certified Security Engineer (PCNSE) and Palo Alto Networks Certified Network Security Administrator (PCNSA) exams? Get a few pointers on study guides and topics and learn about certification.

 

Will the PCNSE and PCNSA exams cover PAN-OS 9.0?

The PCNSE and the PCNSA exams will cover topics related to PAN-OS 9.0 software, including Panorama, GlobalProtect, and other aspects of the network security platform by Palo Alto Networks. This is essential material that a firewall network engineer needs to know to design, install, configure, maintain, and troubleshoot the vast majority of Palo Alto Networks implementations.

 

NOTE: The PCNSE and PCNSA exams will not cover Aperture, Traps, or AutoFocus, so you can rest easy on those topics.

 

Where can I find some quick study guides?

We have a plethora of study material. You can find some quick study guides on the Certification home page. You can also check out the links below:

The study guides for the PCNSE and PCNSA exams provide overviews of the exam. They explain the scope and how a candidate can register for and attempt each exam. The study guides also show the objectives covered by the exam and includes sample questions and resources for candidate preparation.

 

Do I need to retake the PCNSE exam if I have already taken it?

The PCNSE exam has an expiration date of two years with the latest release. Candidates will need to retake the exam every two years (24 months) to keep their certification current. (Policies for rescheduling and canceling an exam will not change).

 

For more information about the PCNSE and PCNSA exams, please review the links below.

Good Luck! And may the Force be with you!

2,203 Views
Ask Questions Get Answers Join the Live Community
Labels