Incorrect User or Password from GUI

Highlighted
L2 Linker

Incorrect User or Password from GUI

We have changed the admin password to something other than the default but now after a period of time we are getting "Incorrect User or Password" when trying to login via the GUI.  A few times before this we getting logged in then kicked out immediately and I had to reboot the device to fix it. But now nothing seems to work. 

 

I can still login via the CLI with expedition user. Is there a way I can add an Expedition user or edit the admin account from the CLI?

 

 

L4 Transporter

Re: Incorrect User or Password from GUI

Is still the issue persisting?

 

This may be related to a database access issue, and the reasons could be:

  • PHP database access parameters have been modified and are now incorrect (php files within /home/userSpace)
  • The OS has been upgraded an libraries for database drivers are now in a non-supported version (this would require recreating an Expedition instance)
  • Database is not up and running (the service mysql is down)

 

L2 Linker

Re: Incorrect User or Password from GUI

@dgildelaig Thanks again for your help. As you mention it was an issue with mysql being down. But looks like something might be corrupt since our conversion of the origional beta tool from Fusion to ESX. 

 

To be safe we will probably build a new Expedition and migrate our projects if needed. 

 

 

L1 Bithead

Re: Incorrect User or Password from GUI

I am experiencing the same issue. I can login immediately after rebooting Expedition using the "admin" account. I cannot login using any LDAP accounts or using admin credentials after logging out or waiting to login.

 

  • Which file houses the database paramenters? userDefinitions.php?
  • The OS has not been upgraded, still on 16.04.5 LTS. Upgraded to Expedition 1.1.3 yesterday using the update commands.
  • The mysql service is running.

 

L1 Bithead

Re: Incorrect User or Password from GUI

Found the issue, how would this be resolved?

 

> service mysql status

 

Jan 17 15:52:20 Expedition mysqld[1693]: 2019-01-17 15:52:20 140514870733568 [Warning] Aborted connection 106 to db: 'RealTimeUpdates' user: 'root' host: 'localhost' (Got timeout reading communication pac
Jan 17 15:52:20 Expedition mysqld[1693]: 2019-01-17 15:52:20 140515157236480 [Warning] Aborted connection 103 to db: 'pandb' user: 'root' host: 'localhost' (Got timeout reading communication packets)
Jan 17 15:52:20 Expedition mysqld[1693]: 2019-01-17 15:52:20 140514871339776 [Warning] Aborted connection 104 to db: 'pandbRBAC' user: 'root' host: 'localhost' (Got timeout reading communication packets)
Jan 17 15:55:20 Expedition mysqld[1693]: 2019-01-17 15:55:20 140515605535488 [Warning] Aborted connection 2 to db: 'pandb' user: 'root' host: 'localhost' (Got timeout reading communication packets)
Jan 17 15:55:20 Expedition mysqld[1693]: 2019-01-17 15:55:20 140515552967424 [Warning] Aborted connection 3 to db: 'pandbRBAC' user: 'root' host: 'localhost' (Got timeout reading communication packets)
Jan 17 15:55:20 Expedition mysqld[1693]: 2019-01-17 15:55:20 140515552664320 [Warning] Aborted connection 4 to db: 'RealTimeUpdates' user: 'root' host: 'localhost' (Got timeout reading communication packe
Jan 17 15:55:20 Expedition mysqld[1693]: 2019-01-17 15:55:20 140515552361216 [Warning] Aborted connection 5 to db: 'RealTimeUpdates' user: 'root' host: 'localhost' (Got timeout reading communication packe
Jan 17 15:56:51 Expedition mysqld[1693]: 2019-01-17 15:56:51 140515456244480 [Warning] Aborted connection 54 to db: 'pandb' user: 'root' host: 'localhost' (Got timeout reading communication packets)
Jan 17 15:56:51 Expedition mysqld[1693]: 2019-01-17 15:56:51 140515160570624 [Warning] Aborted connection 56 to db: 'RealTimeUpdates' user: 'root' host: 'localhost' (Got timeout reading communication pack
Jan 17 15:56:51 Expedition mysqld[1693]: 2019-01-17 15:56:51 140515160267520 [Warning] Aborted connection 57 to db: 'RealTimeUpdates' user: 'root' host: 'localhost' (Got timeout reading communication pack

 

 

Thanks!

L4 Transporter

Re: Incorrect User or Password from GUI

Which version of Mariadb are you using?

 

You can see the installed package by executing the following:

 

apt list --installed | grep mariadb

 

It seems that your database is cutting connections, which should affect the whole Expedition experience.

LDAP module is not set up via php parameters, but you define the parameters in the Servers section, providing the server name, port, prefix, suffix, etc.

 

L1 Bithead

Re: Incorrect User or Password from GUI

Here is the output:

 


libmariadb2/xenial,now 2.0.0-1 amd64 [installed]
libmariadbclient18/now 10.1.35+maria-1~xenial amd64 [installed,upgradable to: 10.1.37+maria-1~xenial]
mariadb-client/now 10.1.35+maria-1~xenial all [installed,upgradable to: 10.1.37+maria-1~xenial]
mariadb-client-10.1/now 10.1.35+maria-1~xenial amd64 [installed,upgradable to: 10.1.37+maria-1~xenial]
mariadb-client-core-10.1/now 10.1.35+maria-1~xenial amd64 [installed,upgradable to: 10.1.37+maria-1~xenial]
mariadb-common/now 10.1.35+maria-1~xenial all [installed,upgradable to: 10.1.37+maria-1~xenial]
mariadb-server/now 10.1.35+maria-1~xenial all [installed,upgradable to: 10.1.37+maria-1~xenial]
mariadb-server-10.1/now 10.1.35+maria-1~xenial amd64 [installed,upgradable to: 10.1.37+maria-1~xenial]
mariadb-server-core-10.1/now 10.1.35+maria-1~xenial amd64 [installed,upgradable to: 10.1.37+maria-1~xenial]

L4 Transporter

Re: Incorrect User or Password from GUI

It does not seem to be an issue related to the Mariadb version, as the one we are using is also 10.1 (subversion 33, tho).

 

Please, send us an email to fwmigrate at paloaltonetworks dot com and we will try to give you support via a Zoom meeting or similar.

 

L1 Bithead

Re: Incorrect User or Password from GUI

Did you guys ever talk about a way to reset the GUI admin password via the expedition user in the CLI?  I can't seem to find a way to do that.  My services look good, We did do an update so there is a possibility of the corruption you mentioned.  Is there a way to do a password reset through the CLI?

Thanks,

Alex in MT

L0 Member

Re: Incorrect User or Password from GUI

Hi, did you find a way to password reset through the CLI?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!