- Access exclusive content
- Connect with peers
- Share your expertise
- Find support resources
08-26-2026 09:03 PM - edited 08-26-2026 09:08 PM
Hello experts,
We plan to get the FIM module on top of my XDR.
Having set up with FIM Profile and Policy, we could be able to see those events successfully.
with the following information:
2. Dataset and Presets for FIM
xdr_datadataset = xdr_data | filter fim_event = true
Since this FIM event will be dependent on 5 mins heartbeat (to upload the telemetry to Cortex) , this would be late if we detected the deface of html.
So , the target we would like to trigger an issue when FIM events detected for instance notification.
We did a test a correlation rule, however, it would take up to max 15 mins (heartbeat + correlation rule triggering).
How can I use BIOCs rule for this?
Thanks,
SDG
08-26-2026 09:38 PM
This is my correlation rule,
dataset = xdr_data
| filter fim_event = TRUE
| filter event_type = FILE and event_sub_type in (FILE_CREATE_NEW, FILE_WRITE, FILE_REMOVE, FILE_RENAME)
| fields _time, agent_hostname, event_sub_type, action_file_path, actor_process_image_path
| sort desc _time
Possible to change this to BIOC?
Click Accept as Solution to acknowledge that the answer to your question has been provided.
The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!
These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!
The LIVEcommunity thanks you for your participation!

