Bug in CSV NAT import: only last line imported correctly

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bug in CSV NAT import: only last line imported correctly

L2 Linker



Running Expedition 1.1.21.


Still struggling with Clavister import. Have created CSV files for NAT policy. Address already populated.


When I import the CSV file, the columns 'src' and 'dst' always get the value 'any' not matter what value I put in, except for the last line in the file!!


The very last line in the file populates the columns Source and Destination correctly. This does not work with previous lines. (I have a header line that pre-selects the correct column mapping).


Please fix, is a bit nasty!


/Per Westerlund


PS: If/when you work on this, please take a look at the import logic for tp_source, I want to be able to express interface-hide, and how to do that is not documented as far as I have seen.


Accepted Solutions

Hi all!


I never got a proper followup to this, nor did I find anything in the release notes I managed to find, but when I tried the same example with 1.1.24, it worked as expected. Both columns Source and Destinations are now populated for all rows in the CSV file.

View solution in original post


L5 Sessionator

The CSV import for NAT policies was recently added and will be enhanced in future releases.


I have sucessfully tested the src and dst (using the headers from;to;src;dst;tp_source;tp_destination;service). can you paste an example of one line from your CSV for the NAT policies? before pasting change the IP's of course.



Here is the beginning and end of the input file I'm currently using:


Importing this I get this result:

First importFirst import

If I undo that import and change the order of the two last lines of the file and import it, this is the new result:

Second importSecond import

All previous NAT rules have Source = any, Destination = any. It is always only the last line that shows success in parsing the columns src/dst.

Thanks for reporting this.


We will check this behavior. Do you have those objects already declared in the project where you are going to import the NAT rules?

Yes, this was supposed to be the final touch, everything else (addresses, services, routes, security rules .....) was already imported without complaints, all objects referred to were pre-existing.



Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!