expedition cannot read a mounted location

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

expedition cannot read a mounted location

L1 Bithead

I am trying to import logs exported from the firewalls to a mounted secondary drive. Expedition says it cannot access that location. I tried multiple permission combinations. Permissions are the same as in the locations that it can access ok. The file system is the same too. It can access this directory, untill I mount the external drive to it. Than it fails again.

To set up the secondary drive I followed the steps from the link below. One difference is that it didn't create sdb1, and mounts sdb itself, other than that everythign is like in that PDF, and the mounted drive works, the logs get exported to it. 


Does anyone have any ideas how to get it to work?





1 accepted solution

Accepted Solutions

to clarify, the command to set expedition as the owner is:


sudo chown -R expedition.www-data logs 



View solution in original post


L1 Bithead

Actually, it looks like my problem goes even deeper. I moved the log files to sda. I no longer get an error, but it still doesn't display the logs.




the permissions and owners must also be applied at the directory level. Your screenshots show the permissions and owner at the file level.


$sudo ls -ld ./home/logs


The /home/logs directory must provide privileges for www-data and +x permissions

thanks sjanita,


turns out the folder ownership has to be set to expedition. After I used the command below it stopped giving me this error


sudo chown -R www-data:www-data /hdd

That said, I have more problems now. It doesn't give me the error, but it also doesn't show me the csv files located there. I also tried to change a location of the parquet file store (settings>m.learning). It won't save any changes I make to this location. Somethign had to break after one of the updates. 


I will just blast the VM and start over. 

to clarify, the command to set expedition as the owner is:


sudo chown -R expedition.www-data logs 



  • 1 accepted solution
  • 4 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!