PanOrders Agent is failing.
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

The Enhanced LIVEcommunity Experience is finally here! Learn all about it.

PanOrders Agent is failing.

L1 Bithead

 

 

Greetings,

I'm trying to test the ML part of the tool and PanOrder Agent keeps falling on it's face...

i've updated the linux, expedition-beta packages and tweaked the php

https://live.paloaltonetworks.com/t5/Expedition-Articles/Modifying-mysqli-reconnect-value/ta-p/21922...

 

Seeing this in  log file

 

I'd appreciate the pointer for this agent log file location and just general idea on what is failing here...

 

 

Cheers.

 

------------------------------------------------------------
Thu Dec 20 09:19:43 CST 2018 : Starting readOrders.php
------------------------------------------------------------

Fatal error: Uncaught PhpAmqpLib\Exception\AMQPTimeoutException: The connection timed out after 3 sec while awaiting incoming data in /var/www/html/libs/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Wire/AMQPReader.php:132
Stack trace:
#0 /var/www/html/libs/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Wire/AMQPReader.php(149): PhpAmqpLib\Wire\AMQPReader->wait()
#1 /var/www/html/libs/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Wire/AMQPReader.php(106): PhpAmqpLib\Wire\AMQPReader->rawread(7)
#2 /var/www/html/libs/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Connection/AbstractConnection.php(530): PhpAmqpLib\Wire\AMQPReader->read(7)
#3 /var/www/html/libs/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Connection/AbstractConnection.php(578): PhpAmqpLib\Connection\AbstractConnection->wait_frame(3)
#4 /var/www/html/libs/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Channel/AbstractChannel.php(227): PhpAmqpLib\Connection\AbstractConnection->wait_channel(0, 3)
#5 /var/www/html/libs/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Channel/AbstractChannel.php( in /var/www/html/libs/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Wire/AMQPReader.php on line 132

1 ACCEPTED SOLUTION

Accepted Solutions

L1 Bithead

So editing hosts file with

127.0.0.1     localhost pan-expedition

did  it.

 

 

View solution in original post

3 REPLIES 3

L5 Sessionator

Have you updated something else than Expedition?

"apt-get upgrade" has more effects than "apt-get update" as it would update other packages that may break dependencies in Expedition.

 

The error you see reported is related to a communication package that we are using for the background agent (rabbitMQ).

I wonder if rabbitMQ is not working anymore in your Expedition instance

Is there a way to manually start the PanOrders Agent from the cliimage.png

 

The 'Remediation' button is greyed out

L1 Bithead

So editing hosts file with

127.0.0.1     localhost pan-expedition

did  it.

 

 

View solution in original post

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!