Possible Object Filter Bug?

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

Possible Object Filter Bug?

L2 Linker

I'm having an issue trying to filter my objects list on one of my panoramas to show only the unused objects.  

Here are the steps I'm following:


If I create a brand new project you can see that my Unused objects are a fraction of the total object count. When the issue I'm experiencing occurs one of the issues it causes is that the project will start to report all objects are unused.


Now when I try to filter unused objects I've tried multiple different criteria.  Just Address, or just Shared vsys, or any other combination I've tried with the same results.  In this example I'm using the following parameters.


When I apply the filter I get the please wait progress bar.  The eventually an error.



While this is filter is processing and after the error the mysql process on the server stays at 100% CPU (This is an 8 CPU server)



Now on a side note, on a different Panorama we have that has a slightly smaller rule base, I have let this sit for over an hour, then rebooted the server and it has been hit or miss in getting the correct results. But on this server it is 100% not getting the results.


After an hour and a half the mysql process has subsided.



When I return to Expedition I get this error when trying to navigate.


I try to restart services and I get this error.


I reboot the server and log back in to Expedition I see that now all objects are considered unused.


And when I go into the objects the filter has still not applied.



I've tried several times, with brand new projects, and different combination of filters looking for unused objects and the outcome is the same each time. I had the same issue on a different Panorama and it took several attempts before I got it to work, and that seemed to be luck with how long I waited for the process to run and rebooting the service or server.


Also a thing to note on the panorama that this did worked on was that it didn't matter if I specified only "address", "address-group", "service", "service-group", "tag", or any combination of them for the unused filter, the results would always filter all of the type of objects even if I specified just one.


Just a guess on my part but I think on the back end there may be a flaw in the query that is being run against the mysql database as well as some additional indexing that may need to be added.


Other than that, are there any thoughts on how I can go about getting the results I'm looking for of showing only unused objects?







L6 Presenter

Hi BOKay , 


Could you please export your expedition project as zip file and sent it to fwmigrate@paloaltonetworks.com , we can take a look at it.


Thank you!

Sent. Thank you.

Do you have an upload site I can send to? I get the following rejected email.

... Message Size Violation. Size over 50MB or over 256 attachments or zipped attachment inside with over 256 files.

Hi BOkay, 

Let’s continue the communication via email , we can provide a way for you to sent the project . 
Thank you ! 

Hi @BOkay 


The filter issue has been fixed in latest version v1.1.76.1 , please try to upgrade your expedition to latest version .  Thank you!

  • 5 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!