Running version 1.1.26 Merge done HUNG at Generating Applications vsys/dg:vsys1
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

The Enhanced LIVEcommunity Experience is finally here! Learn all about it.

Running version 1.1.26 Merge done HUNG at Generating Applications vsys/dg:vsys1

L1 Bithead

I have exited the project reloaded the  xx.xml file before I started the merge and I get the same issue Hung at Generating Applications over and over

Daniel Agin
1 ACCEPTED SOLUTION

Accepted Solutions

The issue was the unused custom applications were hanging the merge once they were removed . Then Sandro was able to get a commit and give me a working xml file.

Daniel Agin

View solution in original post

4 REPLIES 4

L4 Transporter

Can you post the output from the error file:

 

$cat /tmp error

Also, how much memory and CPU's have you made available to the Expedition VM?

 

Can you check the output from the file below also:

 

expedition@Expedition:~$ cd /home/userSpace/

 

expedition@Expedition:/home/userSpace$ cat environmentParameters.php

<?php

 

define ('NumCPUs',3);

define ('TotalCPUs',4);

define ('SparkRAM','4743m');

expedition@Expedition:/home/userSpace$

HI Sjanita,

 

See attached output

expedition@Expedition:/tmp$ cat error

Notice: Undefined index: template_extra in /var/www/html/bin/configurations/output/output_function.php on line 148

Warning: get_class() expects parameter 1 to be object, boolean given in /var/www/html/libs/xmlapi.php on line 1734
object(SPHP Fatal error: Uncaught Exception: Wr
Fatal error: Uncaught Exception: Wrong type of input parameters, expected SimpleXMLElement key:value: in /var/www/html/libs/xmlapi.php:1753
Stack trace:
#0 /var/www/html/libs/common/xml/panosxml.php(2116): SimpleXMLElement_append(Object(SimpleXMLElement), false)
#1 /var/www/html/bin/configurations/output/output_function.php(306): xml_applications(Object(SimpleXMLElement), Array, Array)
#2 /var/www/html/bin/configurations/output/output_function.php(25): generate_xml(Array, '4')
#3 {main}
thrown in /var/www/html/libs/xmlapi.php on line 1753
expedition@Expedition:/tmp$

 

expedition@Expedition:/home/userSpace$ cat environmentParameters.php
<?php

define ('NumCPUs',1);
define ('TotalCPUs',1);
define ('SparkRAM','3146m');
expedition@Expedition:/home/userSpace$

 

I have 32 gig of memory , so I can change parms.

 

Thanks for your help 

 

Dan A.

Daniel Agin

The issue was the unused custom applications were hanging the merge once they were removed . Then Sandro was able to get a commit and give me a working xml file.

Daniel Agin

View solution in original post

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!