Expedition 1.2.0 Hotfix Information

cancel
Showing results for 
Search instead for 
Did you mean: 
L5 Sessionator
Did you find this article helpful? Yes No
No ratings

Version 1.2.0  (Date October 21, 2021)

PACKAGE DOWNLOAD

  INFORMATION

Link

https://conversionupdates.paloaltonetworks.com/expedition-updates/expedition_1.2.0.all.deb

sha1sum

2a7d91df15293eaff11ad26f1077d4f04e57637f

apt update
sudo apt-get update; sudo apt-get install expedition-beta
manual update cd /tmp;
wget https://conversionupdates.paloaltonetworks.com/expedition-updates/expedition_1.2.0.all.deb ;
sudo dpkg -i expedition_1.2.0.all.deb;

 

CHANGELOG

Bug

  • [MT-2194] - Panorama DG PBF policy missing forward to vsys action
  • [MT-2206] - Juniper SRX Nested Service Group object migrated without members
  • [MT-2207] - STONESOFT: Calculate Zones

Coming Soon

  • Checkpoint <R80 Interface & Autozone issues (before release 1.2.3)
  • More functionalities to come with Forcepoint configurations: Summary of Jump information. Report on skipped rules due to not-matches, etc.
Rate this article:
Comments
L0 Member

expedition@Expedition:~$ sudo dpkg -i expedition_1.2.0.all.deb
(Reading database ... 149068 files and directories currently installed.)
Preparing to unpack expedition_1.2.0.all.deb ...
Unpacking expedition-beta (1.2.0) over (1.1.113) ...
dpkg-deb (subprocess): cannot copy archive member from 'expedition_1.2.0.all.deb' to decompressor pipe: unexpected end of file or stream
dpkg-deb (subprocess): decompressing archive member: lzma error: unexpected end of input
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive expedition_1.2.0.all.deb (--install):
cannot copy extracted data for './var/www/html/OS/spark/extraLibraries/kafka-clients-0.10.2.1.jar' to '/var/www/html/OS/spark/extraLibraries/kafka-clients-0.10.2.1.jar.dpkg-new': unexpected end of file or stream
Could not open input file: /var/www/html/bin/updates/updateSQL.php
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
/bin/sh: 0: Can't open /var/www/html/OS/startup/pan-readOrders
Could not open input file: /var/www/html/OS/update/snsUpdate.php
Checking for old projects and Devices what are not Encrypted
Could not open input file: /var/www/html/libs/Security/checkSecurity.php
In order to make BestPractices to work you have run this script to upgrade python to version 3.7
bash /var/www/html/OS/BPA/updateBPA306.sh
cp: cannot stat '/var/www/html/OS/spark/config/log4j.properties': No such file or directory
its recommended to run after install: apt-get -y -f install
its recommended to run after install: sudo apt-get autoremove
Errors were encountered while processing:
expedition_1.2.0.all.deb

L1 Bithead

So I know we are not supposed to do general updates to the OS, but I ran apt update and see this:

E: Failed to fetch https://www.rabbitmq.com/debian/dists/testing/main/binary-amd64/Packages 404 OK [IP: 172.67.16.25 443]

 

I only recently deployed fresh from the installation script onto an Ubuntu 20.08 VM, but it looks like the appropriate place to get rabbitmq is here: https://www.rabbitmq.com/install-debian.html

 

Does this need to be corrected in the installation script?  Should it be corrected in a live system?

L5 Sessionator

We are aware of this issue , please stay tune , in the mean time, please run a manully downgrade back to v1.1.113 by issuing below commands: 

 

$cd /tmp
$wget https://conversionupdates.paloaltonetworks.com/expedition-updates/expedition_1.1.113.all.deb 
$sudo dpkg -i expedition_1.1.113.all.deb

L5 Sessionator

The issue is solved, please try download and install the package again . it should work now.   

L0 Member

Yup, all is good now. Thanks!

 

Register or Sign-in
Contributors
Article Dashboard
Version history
Last update:
‎10-21-2021 09:36 AM
Updated by: