500 Internal Server Error - CAPTIVE PORTAL

Reply
Highlighted
L3 Networker

500 Internal Server Error - CAPTIVE PORTAL

Dears,

 

PA220 with interfaces as per below

ethernet1/4 19 1 Local-Network vr:RT-LAN 0 172.26.57.1/25
ethernet1/5 20 1 Local-Network vr:RT-LAN 0 172.26.57.129/26
ethernet1/7.105 269 1 Local-Network vr:RT-LAN 105 172.26.59.1/27
ethernet1/7.106 270 1 Local-Network vr:RT-LAN 106 172.26.59.97/27

Captive portal already configured and we double checked everything... All looks good.

PA220, PanOS 8.0.8

 

All tries to access Captive Portal shows up error message: 500 Internal Server Error

- We tried to access all IPs with mgnt profile "response pages"

- Redirect is OK, but users face that error message

- Already tried restart web-server process and mgnt server process

- This has nothing to do with HTTPS Certificate distribution, that is just a test forcing Caotive portal to show up (works on any other box we have)

 

Test #1 ip 172.26.57.1 port 6082

ScreenShot640.jpg

 

Test #2 ip 172.26.57.129 port 6082

ScreenShot642.jpg

 

 

Test #3 ip 172.26.59.1 port 6082ScreenShot644.jpg

 

Test #4 ip 172.26.59.97 port 6082

ScreenShot646.jpg

 

 


Accepted Solutions
Highlighted
L3 Networker

Dears

 

I found the problem

 

The Captive Portal URL was modified in Version 8.X

 

Captive portal URL PANOS v7.x

https://X.X.X.X:6082/php/uid.php?vsys=1&url=http://www.URL.com

 

Captive portal URL PANOS v8.x

https://X.X.X.X:6082/php/uid.php?vsys=1&rule=&url=http://www.URL.com

View solution in original post


All Replies
Highlighted
Cyber Elite

Hello,

If your captive portal is n the PAN itself, you might want to call TechSupport as this could be a larger issue. 

 

Regards,

Highlighted
L5 Sessionator

Hi @FabioGarcia,

 

Can you also try to restart the User-ID process? This has fixed this issue for us in the past. Otherwise, log a TAC case like @OtakarKlier has said.

 

Thanks,

Luke.

 

Highlighted
L0 Member

thanks for yout help!

 

I did that but no joy... opening a Support Case now... thx again

Highlighted
L3 Networker

Dears

 

I found the problem

 

The Captive Portal URL was modified in Version 8.X

 

Captive portal URL PANOS v7.x

https://X.X.X.X:6082/php/uid.php?vsys=1&url=http://www.URL.com

 

Captive portal URL PANOS v8.x

https://X.X.X.X:6082/php/uid.php?vsys=1&rule=&url=http://www.URL.com

View solution in original post

Highlighted
L0 Member

This Solution was helpful.

We moved from 7.1.14 to 8.1.12

 

We modified our Captive URL like, 

https://example.com:6082/php/uid.php?vsys=1

to

https://example.com:6082/php/uid.php?vsys=1rule=&

 

Thank you,

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!