CentOS 7.4 Compatibility with VM-Firewals?

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements

CentOS 7.4 Compatibility with VM-Firewals?

L1 Bithead

Hello good morning, someone has tested the vm series firewall, with the latest version of CentOS 7.4.

Is there a problem or incompatibility?

 

Thanks

4 REPLIES 4

Cyber Elite
Cyber Elite

In which way do you mean 'compatible' ?

 

you'll need to run VMWare ESXi/NSX, Citrix SDX, Hyper-V or KVM as a virtualization layer before you can deploy a firewall

 

https://www.paloaltonetworks.com/products/secure-the-network/virtualized-next-generation-firewall/vm...

 

Tom Piens
PANgurus - Strata specialist; config reviews, policy optimization

Hello, in my case, I would use KVM.

I have seen on the web, that the support of the vm series firewall, using the software version 8.0. Work with CentosOS 7.2.

But I don't know if version 7.4 could cause any problems, from the virtual firewall running on KVM.
Thank you

@reaper
Section VM‐Series on KVM— Requirements and Prerequisites in VM-Series 8.0 Deployment Guide states:
CentOS/RedHat Enterprise Linux: 7.2 (QEMU‐KVM 1.5.3 and libvirt 2.0.0)
as Software Versions Requirements. So the question is about compatibility with higher versions of QEMU‐KVM and libvirt.
CentOS 7.4 comes with libvirt-3.2.0-14.el7.x86_64.rpm package in OS repository.
Weird that CentOS 7.2 comes with libvirt-1.2.17-13.el7.x86_64.rpm package in OS repository and libvirt-1.2.17-13.el7_2.2.x86_64.rpm in Updates repository. I do not how to achive exactly the libvirt 2.0.0 version.
@baron1234

It seems that product documentation is lacking clear requirements. I will try to run PA-VM in KVM on CentOS 7.4.

 

@baron1234

I have successfully setup PA-VM (PAN-OS 8.0.6-h3) on freshly updated CentOS 7.4 with KVM installed on Supermicro SuperServer 5018D-FN8T. Tested passing traffic through the I210-based and I350-based interfaces, in bridge, PCI Passthrough, SR-IOV (only I350).

However the SoC 10 GbE (X552) interfaces were not recognized. Started working with PANW TAC on this issue.

  • 3248 Views
  • 4 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!