Cisco Policy Based VPN - ProxyID Query

Reply
Highlighted
L0 Member

Cisco Policy Based VPN - ProxyID Query

Hi everyone,

 

I am receiving the below error on a Palo to Cisco policy-based VPN.

 

'IKE phase-2 negotiation failed when processing proxy ID. cannot find matching phase-2 tunnel for received proxy ID. received local id: 10.45.33.253/32 type IPv4_address protocol 0 port 0, received remote id: 10.104.58.0/24 type IPv4_subnet protocol 0 port 0.'

 

Does the proxy-ID to crypto-map ordering make a difference (i.e do they have to match EXACTLY)?

 

Palo Alto Proxy-ID

PROXY-1 10.45.33.253/32 10.209.11.0/24 any

PROXY-2 10.45.33.254/32 10.209.11.0/24 any

PROXY-3 10.45.33.253/32 10.218.8.0/24 any

PROXY-4 10.45.33.254/32 10.219.8.0/24 any

PROXY-5 10.45.33.253/32 10.104.58.0/24 any

PROXY-6 10.45.33.254/32 10.104.58.0/24 any

 

Cisco Crypto-Map

permit ip 10.209.11.0 0.0.0.255 host 10.45.33.253
permit ip 10.209.11.0 0.0.0.255 host 10.45.33.254
permit ip 10.104.58.0 0.0.0.255 host 10.45.33.253
permit ip 10.104.58.0 0.0.0.255 host 10.45.33.254
permit ip 10.218.8.0 0.0.0.255 host 10.45.33.253
permit ip 10.218.8.0 0.0.0.255 host 10.45.33.254
!

 

Would the above configuration caused phase-2 to fail simply due to the ordering?

 

I appreciate any assistance

 

Baz

 

Highlighted
L4 Transporter

Re: Cisco Policy Based VPN - ProxyID Query

Hi @baz00r 

 

I read the article below and it says PA doesn't support policy based VPN.

https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000ClW8CAK

 

Also, the KB below doesn't mention anything specific about order of proxy-ids.

Just talks about selecting PA as either initiator or responder when using multiple proxy-ids.

https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000ClUFCA0

Highlighted
L0 Member

Re: Cisco Policy Based VPN - ProxyID Query

Hi Farzana,

 

They don't support policy based natively (I suppose initiating) but through the use of proxy-ID's they can accept and terminate policy based VPNS (in fact we have this working already with multiple clients).

 

But when we update the proxy ID configuration the phase-2 neg fails.

 

Thank you for those articles below, I had seen those before and unfortunately don't really shed any light on my specific issue. Thank you for your response though!!

 

Baz

 

 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!