Global Protect stuck in "Connecting", "Still Working"

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

Global Protect stuck in "Connecting", "Still Working"

L1 Bithead

Hi there guys, I have a Macbook Pro with Catalina v10.15.4 and I am here because I am out of moves on how to make this software to work. 


Troubleshooting I've tried so far:

1) Tried going to privacy and security in the settings to allow the software thru there but I never saw that as an option. I have installed and uninstalled the software many times and still I do not get the option to allow it.

2) I have tried allowing the kexts by restarting the computer in recovery mode and inputing the command to add it and nothing seems to happen after inputing the command.

3) I have removed all antivirus and firewall software from my mac to make sure none of these were blocking global protect. Then again, I have installed and uninstalled the software completely many times with no success.


Is there anything else I can try to make this to work?

A man needs a name...

Cyber Elite
Cyber Elite

which version of GlobalProtect are you installing?

5.0.4 is the minimum but 5.1.3 may be worth a shot



Tom Piens
PANgurus - Strata specialist; config reviews, policy optimization

The version I am using right now which is the one available from our download page at our campus website is 5.2.1-12. This is the only version available in our portal, how do you get a different version of the software?

A man needs a name...

L4 Transporter

Hi @allenwarez ,


GP Agent log might give you more details. If the issue is because kernel is not allowing the program to run,

restart the mac with command+R to recovery mode. Open terminal and put "spctl kext-consent add PXPZ95SK77". Then reinstall the GP.

I tried allowing the kext via recovery mode again but it did not work. I have the logs but I have no clue what they mean. The PanGPA log keeps repeating the same errors.


P1621-T26895 May 15 10:58:39:275295 Info ( 228): InitConnection ...
P1621-T26895 May 15 10:58:39:275304 Debug(  57): fd still open before connect
P1621-T26895 May 15 10:58:39:275433 Error(  80): CPanSocket::Connect - Failed to connect to server at port:4767
P1621-T26895 May 15 10:58:39:275442 Error( 232): Cannot connect to service, error: 61
P1621-T26895 May 15 10:58:39:275446 Debug(1198): CPanCommand::Send - InitConnection failed again. return without sent.



A man needs a name...

Hi @allenwarez ,


By default, if the service start is fine, the GP service should listen on port 4767. In your case it is clear that the service is not started yet, the kernel is stopping it. normally 'spctl kext-consent add PXPZ95SK77' and a reinstall should work along with allowing GP to run ( 'system preferences > security')


GP version 5.0.4 is minimum and latest is 5.1.3 (there is no GP version 5.2.x )

I have tried the above many times. Allowing the kext imputing the command you provided and it is still doing the same thing. I actually had to go to my office in person to solve a few issues that required VPN access since GP refuses to work on my computer. Attached is a screenshot showing you what happens after I allow the kext thru the command line via recovery boot then re-installing it. Also, look at the version of this software.


A man needs a name...

L0 Member

I was having the same problem and in around about way landed on this - which fixed it. Not sure if addresses your problem, but FYI

That is the problem, I have already tried this fix as said in the above messages. The problem still persists. I never got an option to allow the software to run like it is shown in the screenshot above.

A man needs a name...

Hi! I too am facing the same problem . Were you able to find a solution?
If so , please post it here .
Thanks 🙂

Still have not found a solution yet. It’s not like I’m not troubleshooting it right, I work for a group of programmers at a busy campus and I’ve tried step by step all of the fixes provided above and from other sites and nothing seems to work.

A man needs a name...

Yes ,me too . Have tried everything given on web but still haven't been able to find a solution to this. Anyway, i have added same question in the hope that someone else might answer it . Lets see! 

Try upgrading your OS to latest version . It solved my problem . I upgraded my OS version to Catalina(10.15.5) and reinstalled globalProtect VPN , its working alright . Hope it helps!

Thank you Pal, however, I usually install the newest OS as soon as it comes out so I already had it when I installed Global Protect the first time. 

A man needs a name...

L0 Member

I don't know if this has been resolved yet, but have you tried going repairing it? 


Go to you client portal, download the file and click repair. 

  • 23 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!