How to get Applications using XML API

Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to get Applications using XML API

L1 Bithead

I am trying to get a list of applications, or a single application using the XML API. I have tried the following:






None of these work. What am I missing?




Cyber Elite
Cyber Elite




The above is a perfectly valid API call and will respond with the following XML response. What is the response actually telling you when you make the call? Are you actually authenticated? 


<response status="success" code="19">
<result total-count="1" count="1">
<entry id="1" name="icmp" ori_country="USA" ori_language="English">
<tunnel-other-application minver="3.0.0">yes</tunnel-other-application>
<decode minver="3.0.0">icmp</decode>
<entry name="Wikipedia">
<tunnel-applications minver="3.0.0">
<member minver="3.0.0">ping</member>

Well, thats interesting... it now works for me, so I'm not sure what I did wrong. What I am trying to do is get or edit the Tags attribute, but I don't see Tags in the returned XML. I'm guessing that the Application data is in the config/predefined since we can't change it, but maybe the Tags attribute is in the config/shared data? Do you know where I can find that?


Totally different element in the configuration. Tags are actually present under <application-tag> instead of <application>. So the API request to show tags for icmp would be the following:


When I used the command you gave above I get "<response status="success" code="7"><result /></response>". My firewall is 8.0.13.


Since I am trying to change it on a Panorama, wouldn't I need something like "api/?type=config&action=get&xpath=/config/devices/application-tag/entry[@name='icmp']"? That fails with the same message


You can utilize the API browser to figure out the exact command that you would need to utilize, the example that I gave you was off of a firewall not Panorama. 

Thank you for the reply. The problem is that I can't find any reference to application-tag in the API browser. I have tried to go down every path but would expect it to be in the Configuration Commands->Shared path. But there is no reference to this object anywhere that I look. This is on a Panorama running 9.0.2. I have spent hours Googling and on the Palo site and can't find any references to application-tag. So I'm out of ideas.

OK, in case anyone would like the solution to this. I was looking in the wrong direction. When you are working with Panorama, it is the Devices->Device-Group path. Below is for the Global Device Group.


To get the application-tag:



And to edit the application-tag:



Using the tag "empty" you can clear the tag, but strangely enough, it sets the "Remove Tag Inheritance" flag. Anyone know why it does that?



  • 7 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!