Missing PANGPS Virtual Ethernet Adapter

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Missing PANGPS Virtual Ethernet Adapter

L1 Bithead

When launching Global Protect for the first time, the computer will prompt for the portal to connect to. The portal information will be enter and when hitting connect it will only display "Connecting...". It will not get to the username and password login screen. While working on the computer, it was identified that the PANGPS Virtual Ethernet Adapter did not show up in the Network Adapter list. Also the virtual adapter will not appear under the Network list in Device Manager. Multiply uninstalls and reinstalls have been performed along with restarting computer but the virtual adapater will not be installed. The steps listed in the article was followed but no success (https://live.paloaltonetworks.com/t5/Management-Articles/Error-Failed-to-find-PANGP-virtual-adapter-...). Any help will be welcome.

1 ACCEPTED SOLUTION

Accepted Solutions

L1 Bithead

This issue resolved itself over the weekend. Computer was not touch but the virtual adaptor appeared and Global Protect started working properly. 

View solution in original post

6 REPLIES 6

Cyber Elite
Cyber Elite

@JoshLamberth,

The PAN uninstall process does a bad job at cleaning up after itself. If you go HERE and verify that the associated registry keys and the Palo Alto Networks Program Files folder is actually cleared out. 

L4 Transporter

We see this from time to time as well, oddly enough it seems to only happen for us with the 32-bit client. the solution for us has been to have the user bring the device in and then uninstall and reinstall the GP client then double check to make sure the virtual NIC is there

@BPry,

I followed the referenced article but the it did not help for this computer. I first uninstall Global Protect and noticed that regedit entry and the SC was already deleted. So the uninstaller did removed it for me. I reinstalled GP  but the Virtual Adaptor did not appear still. So I decided to delete the registry entry first and delete the SC manually. Both successful. Reinstall of GP but still no Virtual adaptor.

@hshawn,

Sadly this has computer has seen many uninstalls and reinstalls of Global Protect but still no virtual adaptor showing up.

L1 Bithead

This issue resolved itself over the weekend. Computer was not touch but the virtual adaptor appeared and Global Protect started working properly. 

L0 Member

I got this problem. No matter how many times I re-install, what I clean in the registry, the driver is not installed.

 

What worked for me was:

- Install Global Protect from the Windows app store (driver is also not installed)

- Create a VPN connection from the Windows VPN configuration and choose as a provider 'Global Protect'.

- Enter the credentials as usual.

- Try to connect, it should work.

- The next issue is with the DNS is not being provided or obtained from the VPN server. Even you configure it in the Connection settings of the IPv4.

- To make this work, ask someone to provide you with the IP of the DNS.

- Once connected use this command (as admin) to set the DNS:

netsh interface ip set dns name="YOUR_CONNECTION_NAME" static xxx.xxx.xxx.xxx

Where xxx.xxx.xxx.xxx is the IP of the DNS.

- If you want to automate the whole process, you can create a bat file like:

rasdial "YOUR_CONNECTION_NAME"
netsh interface ip set dns name="YOUR_CONNECTION_NAMEt" static xxx.xxx.xxx.xxx

 

Hope this helps.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!