PanAgent Service Not Running after 3.1 Upgrade
cancel
Showing results for 
Search instead for 
Did you mean: 

PanAgent Service Not Running after 3.1 Upgrade

L4 Transporter

Hello,

I am unable to keep the PanAgent service "running" after upgrading to 3.1.  I was warned about the service going back to "local user" after upgrade - and I have gone back and added the previous domain account.  The account validates and the service starts - but it will not stay running for more than about a minute.  There is nothing showing up in the Event Viewer to indicate why the service is stopping.  I did the upgrade of 3.1 over the previous version of 3.0.  I did not uninstall 3.0 prior.  Is that necessary? I have not upgraded Panorama and the PAN devices to 3.1 as of yet.  That is planned for tomorrow.  Any issues with the devices still on 3.0? Thank you for your assistance.

4 REPLIES 4

L5 Sessionator

Loading PANAgent 3.1 will uninstall 3.0 in the process so there is no need to take that extra step.  There also is no issue with running PANAgent 3.1 in combination with 3.0  on the PAN.   It sounds like you've hit a bug that we've logged.  Are you getting an error in the Agent Status box on the PANAgent?  One work around has been to go into File>Debug and choose either Debug or Verbose and restart the agent.  Whether that does or doesn't solve your problem, please open a case with Support so that we can log your case against the bug.  

L4 Transporter

Trying the debug change now.  It appears the issue is MOS2? That is showing up in the event logs with all kinds of errors and also won't stay running.  I didn't realize at first that it was part of the agent as there is no description listed on the service.  Is it possible to have engineering add some description to that service - so that we know it is part of the PAN agent? I thought it was a rogue service at first.  Thanks.  If the debug doesn't work - I will open a case.  Can I revert back to 3.0 if all the PAN devices are on 3.1? Not having it running is effecting some application access.  Thanks!

Mike

L5 Sessionator

MOS2 isn't part of the agent from what I can gather so open a case with those logs.  While you can use the 3.1 agent with a 3.0 PAN, the reverse is not true.  If the PAN is on 3.1, the 3.0 or lower agent won't work.

L4 Transporter

I found what the MOS2 was.  Not related. Thanks.  The debug setting is working at this point.  I will open a case though.  Thanks!

Mike

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!