Settings missing in Management Interface

cancel
Showing results for 
Search instead for 
Did you mean: 

Settings missing in Management Interface

L2 Linker

I cannot see any option to change any Management Interface settings under Device > Setup > Interface.

>show system info is showing ip-assignment: dhcp. I need to change it to Static.

I have tried the commands below but no change.

> configure
# set deviceconfig system type static

# commit

Invalid configuration. Please fix errors and try again.

 

Using PANOS 10.1.0 and this PA-VM is deployed through Azure.

Please help.

 

Interface Settings.jpg

2 REPLIES 2

Cyber Elite
Cyber Elite

Hello,

If you want to set the static IP via CLI, you'll need the following commands:

 

configure
set deviceconfig system ip-address <IP address> netmask <subnet mask> default-gateway <gateway>
set deviceconfig system dns-setting servers primary <IP of internal DNS server if no internal DNS server use 208.67.220.220 >
set deviceconfig system ntp-servers primary-ntp-server ntp-server-address <IP of NTP server or use us.pool.ntp.org>
commit

 

Regards,

Hi @OtakarKlier 

 

Thank you for your response. I tried the commands above but getting this error below.

 

Validation Error:
deviceconfig -> system -> type -> dhcp-client is missing 'send-client-id'
deviceconfig -> system -> type -> dhcp-client is invalid
[edit]

 

Please advise.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!