Unable to access Windows Store (Windows 10 + GP 3.0.2)

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to access Windows Store (Windows 10 + GP 3.0.2)

L7 Applicator



Does anyone else also have problems to access the windows store when connected with global protect vpn?

Actually the problem really only is the windows store app. Everything else works perfectly (internet access, accessing corporate ressources, internal websites, fileshares, ...). The store app only displays that I should check my internet connection and the error code 0x80072EFD.

The firewall has 7.0.6 installed and we have configured the vpn with the default route into the vpn tunnel.





L7 Applicator


Did you already verify? Anyway, I will also try your suggestion probably tomorrow. And if this does not help either, at least I have some more information for another supportcase.


@Mick_Ball @BPry

--> the power of the (Live) community!

@Remo, hi.

yes this worked.

i tested a couple of days ago on a domIn member win10 device that i have been trying to fix ms store for over a year.

i also tested on a user device that is so heavily restricted it sometimes prevents you from wiping your own arse, and this too worked well.


our wintel engineers are happy with the GP change and are about to roll out to pilot group of 500.



However... when i am disconnected from VPN and connected to the LAN my store is failing...


my investigations continue...

OK, I is fik innit...


my group policy updated and put the settings back....



Almost 2 years ago I created this topic ... and now the problem finally is resolved and the topic has an accepted solution. The solution also worked in my tests!

Thank you very very much @Mick_Ball



Im facing the same problem. WStore is working using LAN, but with GP is not working. Error:" you need to check internet". We have through GP.


How did you solve this?



You need to set these settings VIA GP / Or Local policy for testing

Open up gpedit on your local device

Computer Configuration/Administrator Templates/Network/Network Isolation

Enable Subnet Definitions are authoritative

Private Network ranges for Apps Enable

Then add your internal network subnet range IE

Restart your device and hopefully your windows store is working

Hi all.


Rather than duplicate my post from MS TechNet, I've decided to link here.  I've posted my (possibly incorrect) analysis of 'WHY' this issue happens, and 'HOW' the group policy "fixes" the issue.




I admit fully my assumptions could be wrong, but I have done quite a bit of (somewhat fruitless) digging with Microsoft on this one.

- rp

This fixed my issue too. Thanks for posting!

L1 Bithead

For those interested in the background of 'why', Microsoft has posted a blog today on this topic:

Diagnosing Network Isolation Issues - Microsoft Tech Community

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!