Updated custom response page doesn't show

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Updated custom response page doesn't show

Not applicable

Hi all

First post, better behave Smiley Happy I've been fiddling around with the antivirus block page on our PA5050-boxes with panos 4.1.4 but for some reason the page I upload to the boxes won't show. It did change once (uncertain why), but if I now try to either restore the default or upload an updated block page, nothing happens, the box keep displaying the page I'm so desperately trying to get rid of.

Any ideas? I've tried renaming the html-file, tried both .htm and .html as file suffix, uploaded it as a shared custom response page as well as to the specific v-sys..nothing seems to do the trick.

Thankful for any advice



L6 Presenter

I guess you already tried to commit just after your upload?

Aye, after each restore default as well as after each upload (which is confirmed by the "upload succesful" or similar). No warnings or anything, the commit which is succesful is followed by a config sync to the HA pair (we have an active-passive setup) so all really looks as it would after any other config change.

Could it be that the response pages are not synced and when you do your commits every other time the unit who were active (and you configured) becomes passive and suddently the other unit is active who uses the old response page?

Good thinking, thanks for you effort mikand. However, the primary remains primary, just uploading a response page and committing doesn't fail over to the backup. I also verified that the backup device was in sync with the primary before testing. I've tried multiple browsers, emptied browser cache, used new machines..they all display the same, incorrect block page. Oddly enough, if I export the custom block page from the device it's the correct one, but the page that's shown when testing (I'm using the malware test file from eicar.org) it's still the wrong one. Unfortunately I can't reboot the device as the HA pair is unpatched, but I have tried rebooting both web and management server without luck.. Argh!

Just updating my own case here.. Now, after hours of waiting the new block page suddenly showed up, almost as if the update was done on a schedule rather than on demand.

Does that mean it just started working and you didn't have to change anything?  We are encountering the same issue on a PA-500 with 4.1.3

L5 Sessionator

Hi Mike,

It sounds like you're running into a reported issue we've encountered here. There is a fix in 4.1.5 for this. I believe as a work-around you can edit parts of the profile in the security rule to force the response page switch.


  • 7 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!