Unable to install GlobalProtect

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to install GlobalProtect

L1 Bithead

Hi, everybody.

I am unable to install GlobalProtect (64 bits). I need it to connect to my work VPN.

When I open the installer, the following message appears: "There is a problem with this Windows Installer package. A dll required for this install to complete could not be run. Contact your support personnel or package vendor."

 

IT support from my company hasn't been able to help me yet.

 

I think I had installed this program last year and then I uninstalled it because I didn't need after all. But now it is the only way to connect to the VPN.

 

Thanks!

6 REPLIES 6

Hi @nadiasb ,

Can you provide little more information:

- What Windows version are you using?

- What GlobalProtect version are you trying to install?

- How did you get the installation file? Did your IT support sent to you, or you download it from somewhere?

- Have you tried to download the installation file from VPN portal? If you open your company vpn address (that you use to connect with GlobalProtect) with normal web browser (specify https:// because there is no automatica redirection from http to https), you probably will be prompted to enter your credentials, after that you should see links to download GlobalProtect installation file. (Note that your IT support may have disable this access)

Hi @aleksandar.astardzhiev, thanks for your answer!

-I'm using Windows 10 Home Single Language 22H2 (64 bits)

-I tried to install the Windows 64 bit GlobalProtect agent (I don't have more information about the version of the installer)

-I got it from my company VPN portal

 

Hi @nadiasb ,

My initial guess was that you may be trying to install some old version of GlobalProtect which is compatiable with your OS.

Windows 10 is supported by GlobalProtect for a very long time, so what ever version you are trying it should work... Or at least if you are trying one of the theses version - 5.1, 5.2, 6.0, 6.1 or 6.2 - https://docs.paloaltonetworks.com/compatibility-matrix/globalprotect/where-can-i-install-the-globalp...

 

As we still don't know what GP version you are trying I wouldn't rule this out, yet:

- Can you ask your IT team - What GlobalProtect version is currently active on Palo Alto firewall?

- You mentioned that you used GP before, but you remove it. Have you changed your OS since than?

Hi @aleksandar.astardzhiev 

I was able to install it in an old notebook that I don't use anymore. The software version is 5.2.8-23.

I think I haven't changed my OS since that time I installed the software. I believe I installed it when I bought this notebook and couldn't connect to the VPN in the usual way (but then I could and I uninstalled it)

 

Thanks!

Hey @nadiasb ,

5.2.8 should definetely work with Windows 10.

I would personally prefer 5.2.13 (as it is the preffered by Palo Alto support - https://live.paloaltonetworks.com/t5/customer-resources/support-pan-os-software-release-guidance/ta-... ). You may ask your support to provide you with 5.2.13 (they can download it manually from Palo Alto support portal), but I have little hopes that this will made any difference.

 

I haven't seen such issue so far, but based on the above (compatiable version, msi downloaded directly from GP portal) I believe we can rule out a faulty installation package. Which means the probablem could be in your laptop missing some dependencies (which probably is obvious by the error you receive)

 

To be honest I am not exactly sure what are GlobalProtect dependencies, but if you look here - https://live.paloaltonetworks.com/t5/globalprotect-discussions/globalprotect-5-2-6-available/m-p/401... it may needs some .NET framework

 

 

What I could suggest is to try to install GP again, but this time using command prompt. This will allow you to specify log file where GP installation package will write logs related to the installation process. Try the following

1. Open elevated (as Administrator) CMD/Terminal prompt in the same directory wher you have downloaded the GP

2. Enter the following command

C:\Users\User\Downloads>msiexec.exe /i GlobalProtect.msi /l+ GPinstall.log 

 This should generate text file (in the same directory from which you executed the command).

If yes, can you share it here? Feel free to obfuscate any user/hostnames (but I don't remember such to be logged)

Hi @aleksandar.astardzhiev !

I paid attention to what you said about versions so I told IT support and they gave me a prior version 5.1.1-12 and it worked! I've installed and it is working!

 

I think yesterday they did what you suggest with CMD but they were going to look more into that. The log says the following:

=== Verbose logging started: 5/7/2023 20:20:02 Build type: SHIP UNICODE 5.00.10011.00 Calling process: C:\Windows\system32\msiexec.exe ===
MSI (c) (3C:18) [20:20:02:452]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (3C:18) [20:20:02:453]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (3C:88) [20:20:02:503]: Resetting cached policy values
MSI (c) (3C:88) [20:20:02:503]: Machine policy value 'Debug' is 0
MSI (c) (3C:88) [20:20:02:503]: ******* RunEngine:
******* Product: GlobalProtect64.msi
******* Action:
******* CommandLine: **********
MSI (c) (3C:88) [20:20:02:505]: Note: 1: 2203 2: GlobalProtect64.msi 3: -2147287038
MSI (c) (3C:88) [20:20:02:506]: MainEngineThread is returning 2
=== Verbose logging stopped: 5/7/2023 20:20:02 ===

 

Well, for the time being it is working and I want to thank you because you helped a lot! 

 

  • 2559 Views
  • 6 replies
  • 0 Likes
  • 47 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!