Protecting Admin UI with Duo MFA

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

Protecting Admin UI with Duo MFA

L1 Bithead

I'm attempting to setup Duo MFA with the admin UI of a PA-3220 running PAN-OS 10.2, but have been unsuccessful. I've found that the guide, https://docs.paloaltonetworks.com/pan-os/10-2/pan-os-admin/authentication/configure-multi-factor-aut... is referencing the Duo Access Gateway which is being sunset; new Duo applications using a DAG can no longer be created. Is there any guidance available that includes setting up MFA with PAN-OS 10.2 with Duo SSO?

6 REPLIES 6

Cyber Elite
Cyber Elite

Config should not be any different on firewall side.

If DUO part is unclear then set up DAG profile style and then clone it to new hosted SAML profile.

Enterprise Architect, Security @ Cloud Carib Ltd
Palo Alto Networks certified from 2011

I have an existing DAG profile style application in Duo that I converted to a SAML profile and attempted to use that without success. The firewall side was setup pretty much as described in the current guide.

 

I'll post a screenshot of a failed logon attempt when I can have someone test this configuration again.

Cyber Elite
Cyber Elite

Did you download xml config file from new SAML profile in DUO, imported it into Palo  "SAML Identify Provider" and changed auth to use this new profile?

Enterprise Architect, Security @ Cloud Carib Ltd
Palo Alto Networks certified from 2011

Yes.

L1 Bithead

The error that's produced when a user attempts to log in using SSO indicates the AssertionConsumerServiceURL does not match any configured Assertion Consumer Service URLs. The URL in question is using the internal IP address of the firewall. I'm not sure how that IP address made it into the URL; the application configuration does not specify it.

I've resolved the ACS URL issue (misconfigured from the original DAG application somehow). Now, I just need to accounts not authenticating at the Duo SSO sign-in. Seems to be more of a Duo configuration issue than on the firewall. 

 

Thanks for the assistance!

  • 1801 Views
  • 6 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!