cancel
Showing results for 
Search instead for 
Did you mean: 

Who Me Too'd this topic

Recommended Pan-OS version

L2 Linker

I have a 5220 that I am using as core L3 segmentation router for my 500 user environment. Currently running 9.1.3 Pan-OS and  What version of PAN-OS is recommended for this scenario. Is it generally advised to install the latest version posted on device-software check? 

 

Who Me Too'd this topic