Azure Terraform Bootstrap - cant get this working

Reply
Highlighted
L1 Bithead

Azure Terraform Bootstrap - cant get this working

I am trying to create a vm-series FW in Azure using Terraform. I am following this example:

https://github.com/PaloAltoNetworks/terraform-azurerm-panos-bootstrap

But I get a similar error to this one in the bootstrap status and log.

https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000PP7jCAG

I have tried using the same parameters via the marketplace ARM template  and the bootstrap completes successfully so I think my bootstrap file share is set up correct. 

My snippet of Terraform code looks like this. 

os_profile {
computer_name = var.FirewallVmName
admin_username = var.adminUsername
admin_password = var.adminPassword
custom_data = join(
",",
[
"storage-account=mystgacct",
"access-key=mystgacctkey",
"file-share=myfileshare"
],
)
}

Any pointers are appreciated. Even the CLI commands I need to view what parameters actually get passed into the Vm-series would help.  

Highlighted
L3 Networker

It looks like a network problem.  Could it be route reachability to the bootstrap fileshare?  I'd suggest troubleshooting the network access from the management port once the instance comes online.  

 

The docs for the module are located here:  https://registry.terraform.io/modules/stealthllama/panos-bootstrap/azurerm/1.0.3

Highlighted
L1 Bithead

I tried everything on the connectivity front. The FW doesn't seem to have any connectivity issues out the mgmt port. 

Highlighted
L1 Bithead

I also used the exact same parameters and network config for VM-series via the marketplace template. And it worked perfectly. 

 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!