Play-book Missing required libraries

Reply
Highlighted
L1 Bithead

Play-book Missing required libraries

My play fails when i include an inventory with an output message:

"msg": "Missing required libraries."

This works okay  when I passe the hosts details as a variable from var.yml to my playbook. Not sure what Is wrong but I am testing with the example playbooks in the Git repository.

Tags (1)
Highlighted
L3 Networker

It's likely there's a package dependency that needs to be addressed.  Can you confirm you've installed the following python packages?  If not you can add them with pip install packagename.

 

  • pan-python
  • pandevice
  • xmltodict
  • json
  • ipaddress
Highlighted
L1 Bithead

I think I got all that, Note that this  only happens when I ...

ansible-playbook templates.yml -i <inventory.file> , where the invenrory has {{my-firewall}}
(using)

hosts: my-firewall
connection: local

The play works when I run playbook without -i <invenroty.file  ( hosts: localhost ) and passing my-firewall ip directly to the playbook.yml template.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!