Pulling a PCAP Through Splunk Fails Intermittently

cancel
Showing results for 
Search instead for 
Did you mean: 

Pulling a PCAP Through Splunk Fails Intermittently

L0 Member

I've been working with the Palo app/addons for Splunk. There is the capability to pull a PCAP directly from a firewall (not Panorama) this way. It seems to fail intermittently on several of our firewalls. The errors are either "URLError: reason: [Errno 110] Connection timed out", "URLError: code: 400 reason: Bad Request", or "URLError: reason: [Errno -2] Name or service not known". We cannot figure out the correlation between failures. The devices are running different versions of the OS, sometimes they're primary/sometimes HA...nothing really makes sense. The logs within the Firewall show a successful authentication, but nothing more. The error codes come from the API hit via Splunk. I'm at a loss. The team opened a support case, but the support team said "Support for issues using the API is provided through the DevCenter" and sent us here. So, here I am. Any ideas? 

1 REPLY 1

L0 Member

@kprior201  curious how you setup the App/Addon to pull the PCAP logs from the firewall? 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!