Cherwell Fetch Incident fails

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cherwell Fetch Incident fails

L3 Networker



We use Demisto Version 6.2.0, Build 1271082


If I configure a Cherwell Instance to fetch incident but It fails with the following Error:

Failed to get samples from instance
Error details
Script failed to run: 
Error: [Traceback (most recent call last):
   File "<string>", line 1017, in <module>
 Exception: '<' not supported between instances of 'NoneType' and 'NoneType'
] (2604) (2603)

This error pops up in the Cherwell Instance and in Incidents Classification Editor

How do I solve it?





L2 Linker

Are you using Cherwell Onprem or Cloud?

We use onprem 

As per our doc guide - we officially support and tested with the Cloud SaaS Version:


I am aware that for on-prem Cherwell, Authentication fails. We came up with a local Integration patch.

Apart from that, everything else with the integration appears to work fine. 


Quick fix is you can clone the integration, and make the following changes:


def request_new_access_token(using_refresh):
  #PATCH for on-premise
  url = BASE_URL + "token?auth_mode=Windows"
  #url = BASE_URL + "token"


Vendor docs here:

We already have internal GIT issue (32068) as feature enhancement for this.

Unfortunately, the customer with this issue didn't raise an AHA request to drive change / improvement to our OOTB content.

I recommend doing this here so other customers can upvote to support On-Premises Cherwell in our standard supported content.


Let us know if this works for you!





Hello Jason


Thanks for your quick and proper solution. Sadly it doesn't work on my side.

I still get the same error as above.

I've modified line 126, but didn't helped. The Check/Test of the new service was:

Unexpected error: '<' not supported between instances of 'NoneType' and 'NoneType', traceback: Traceback (most recent call last): File "<string>", line 9133, in <module> File "<string>", line 8840, in test_command File "<string>", line 8629, in fetch_incidents File "<string>", line 8549, in get_all_incidents TypeError: '<' not supported between instances of 'NoneType' and 'NoneType' (85)

First of all I've entered all the credentials we use to connect to Cherwell.

Without "Fetch incidents" and did a test: "Success"

Then I've enabled "Fetch Incidents" - Test - Error above in the spoiler.

If switch back to "Do not fetch" I do get a "Success" again.


Thank you


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!