smb-upload (Server Message Block (SMB) v2): error

Showing results for 
Show  only  | Search instead for 
Did you mean: 

smb-upload (Server Message Block (SMB) v2): error

L0 Member



I want to upload a file from the XSOAR to a server, for this I want to use the smb-upload automation.


Shared map is created, all correct rights are given, credentials in the XSOAR are correct.

For now I'm just testing a simple test.txt file to upload


I'm always running into the same error:

Failed to execute smb-upload command. Error: Received unexpected status from the server: A volume has been accessed for which a file system driver is required that has not yet been loaded. (3221225884) STATUS_FS_DRIVER_REQUIRED: 0xc000019c



Also tried the smb-directory-list to see if it can find anything, but also same error.


In the integration Server Message Block (SMB) v2 settings I tested the connection, this was successful.



Any idea what the issue could be?


L3 Networker

The message says "Received unexpected status from the server" so your configured server itself is sending this error message. For more details about what that message means and how to fix it you're likely going to need to look at documentation relevant to the software you're using as your fileserver.


Can you access the fileshare using the same credentials from a different (non-XSOAR) client?


Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!