Incorrect Username or Password

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Incorrect Username or Password

L1 Bithead

Hello all. I have just installed Expedition but am unable to log in. I get the "Incorrect Username or Password" error.


I have run php /var/www/html/OS/startup/restore/restoreAdmin.php and got the expected reply:

✓ Connected successfully to the database
✓ Admin user found
✓ Admin password restored to: 'paloalto'


Still I cannot log in. Any suggestions? Thanks in advance.



1 accepted solution

Accepted Solutions

L1 Bithead

Figured it out. Simple problem, the 'root@localhost' didn't have a password in MySQL. Added one and it magically started working! Thank you @lychiang for helping.



View solution in original post


L6 Presenter

Hi @TerryDes ,

Couple things you can check:.

1. Make sure you HD has enough space , if there is no space left in / folder , it will prevent you to login.

2. Follow the solution in this article to re-install Expedition:

We have enough space, and tried the second suggestion and it still does not work.

Please follow the steps below to troubleshoot, after each of the steps , try to login to GUI , if you are able to login , you do not need to continue the remaining steps. 
1. Delete the cookies on your browser , and refresh the browser 
2. login to CLI to verify mysql service is up and running by issue below command:
sudo service mysql status 
You should see mysql service is "active(running) , if not , trying to restart the mysql by issue below command:
sudo service mysql restart
If you encounter an error, pelase follow the instructions to view more details on why mysql is not started.
3. Follow the below article to remove tc.log:
4. Verify if all php package are 7.0 by issuing below command:
apt list --installed | grep php 
If there are versions other than 7.0 installed, you will need to re-install the ubuntu VM from scratch.

Thank you for the prompt replies!


1. Have done after every attempt to fix, hasn't worked. Tried different browsers as well (Edge, Chrome)

2. Reply from server:

mariadb.service - MariaDB 10.5.15 database server
Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
Drop-In: /etc/systemd/system/mariadb.service.d
Active: active (running) since Mon 2022-05-16 16:26:52 UTC; 54min ago
Docs: man:mariadbd(8)
Main PID: 1114 (mariadbd)
Status: "Taking your SQL requests now..."
Tasks: 11 (limit: 4612)
Memory: 105.9M
CGroup: /system.slice/mariadb.service
└─1114 /usr/sbin/mariadbd

3. Completed, no change.

4. Reply from server:

libapache2-mod-php7.0/focal,now amd64 [installed]
php-common/focal,now all [installed,automatic]
php7.0-bcmath/focal,now amd64 [installed]
php7.0-bz2/focal,now amd64 [installed]
php7.0-cli/focal,now amd64 [installed,automatic]
php7.0-common/focal,now amd64 [installed,automatic]
php7.0-curl/focal,now amd64 [installed]
php7.0-gd/focal,now amd64 [installed]
php7.0-json/focal,now amd64 [installed,automatic]
php7.0-ldap/focal,now amd64 [installed]
php7.0-mbstring/focal,now amd64 [installed]
php7.0-mcrypt/focal,now amd64 [installed]
php7.0-mysql/focal,now amd64 [installed]
php7.0-opcache/focal,now amd64 [installed]
php7.0-radius/focal,now amd64 [installed]
php7.0-readline/focal,now amd64 [installed,automatic]
php7.0-soap/focal,now amd64 [installed]
php7.0-xml/focal,now amd64 [installed]
php7.0-zip/focal,now amd64 [installed]
php7.0/focal,now all [installed]

L1 Bithead

Figured it out. Simple problem, the 'root@localhost' didn't have a password in MySQL. Added one and it magically started working! Thank you @lychiang for helping.



@TerryDes Can you share the process you used to perform this step? I'm on my second install of Ubuntu and Expedition to troubleshoot the issue of being unable to login using the default username and password included in the guide. I tried to add a password using some commands I found, last install before the wipe, but I'm not sure I did it properly because I was never able to login.


Thank you!

Good morning @trcoates . It has been a while but I believe I used this article: sql - MySQL Error: : 'Access denied for user 'root'@'localhost' - Stack Overflow


And entered this command:

sudo mysql

-- for MySQL
ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'root';

-- for MariaDB
ALTER USER 'root'@'localhost' IDENTIFIED VIA mysql_native_password USING PASSWORD('root');

Hey thanks for getting back so quick. I tried those steps too and I still get "Incorrect user or password" with the default credentials. I've spent enough time on this that I could have just used Notepad++ to copy config to config, so I think I'm going back to that reliable route until PAN can officially support this tool. Thanks for your assistance!

I  had the same problem. the link provided by you help me solve the situation. Slightly different commands for me, but it worked.

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('new_password');


Thank you 

L1 Bithead

What if this doesn't fix the issue? I still cannot login from the gui homepage using default credentials. Looks like mysql/mariadb are runnning and the only error messages are:


"looking for 'mysql' as: /usr/bin/mysql"

"looking for 'mysqlcheck' as as /usr/bin/mysqlcheck


background: I transferred the ubuntu/expedition combo as an ovf form workstation 17 to esxi6.7

  • 1 accepted solution
  • 10 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!