Unable to Save Additional Project Snapshots

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Save Additional Project Snapshots

L2 Linker

I working through a migration project and attempted to save a snapshot, I received a message "Failed, Please delete some existing snapshots" I don't see anyway to delete snapshots. I have tried restarting expedition and am still receiving the error2019-11-08 09_43_42-PDX-Win10-Prod-MCS - Desktop Viewer.png

6 REPLIES 6

L5 Sessionator

Currently, snapshots need to be deleted manually via CLI.

 

The snapshots are located in /home/userSpace/projects/<projectName>/Backups

 

Check there the snapshots that you consider could be removed.

L4 Transporter

Sorry for reviving an old thread but I get permission denied when trying to access the project directory:

 

$ cd /home/userSpace/projects
-bash: cd: /home/userSpace/projects: Permission denied

 

$ pwd
/home/userSpace

 

$ ls -al
total 160
drwxr-xr-x 4 www-data www-data 4096 Dec 1 07:35 .
drwxr-xr-x 5 root root 4096 May 20 2020 ..
drwxr-xr-x 3 www-data www-data 4096 Oct 12 09:27 devices
-rw-r--r-- 1 www-data www-data 82 May 29 2020 environmentParameters.php
-rw-r--r-- 1 www-data www-data 113092 Dec 1 08:00 panReadOrders.log
drwxrw-rw- 4 www-data www-data 4096 Nov 28 16:31 projects
-rw-r--r-- 1 www-data www-data 10 Dec 1 00:00 .reportedDate
-rw-r--r-- 1 www-data www-data 68 Dec 1 07:35 .signatureMAC
-rw-r--r-- 1 www-data www-data 101 Dec 1 07:35 tempEnvironmentParameters.php
-rw-r--r-- 1 root root 654 May 20 2020 userDefinitions.php
-rw-r--r-- 1 www-data www-data 36 May 20 2020 .uuid4
-rw-r--r-- 1 www-data www-data 36 Oct 11 17:44 .uuid5

 

$ ls -al projects
ls: cannot access 'projects/LVIDSFW34202111281631': Permission denied
ls: cannot access 'projects/.': Permission denied
ls: cannot access 'projects/LVIDSFW34': Permission denied
ls: cannot access 'projects/..': Permission denied
total 0
d????????? ? ? ? ? ? .
d????????? ? ? ? ? ? ..
d????????? ? ? ? ? ? Project1
d????????? ? ? ? ? ? Project2

Hello @justamoment 

 

Make sure you are a sudoer and this should grant you access to the folder.

L4 Transporter

Sorry, I should've mentioned this:

 

$ sudo cd /home/userSpace/projects
[sudo] password for admin:
sudo: cd: command not found

Works for me, try going into "sudo su" then changing your path.

L4 Transporter

Ah, I forgot all about sudo su.  That worked - thanks!

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!