Application Blocking page for HTTPS traffic through Web Proxy

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

Application Blocking page for HTTPS traffic through Web Proxy

L4 Transporter

Hello,

I experienced an issue with 'application blocking page' for https traffic through web proxy.

The firewall is configured to decrypt the HTTPS traffic.

Layout : Client -- Palo Alto FW -- Web proxy (Squid)

If the traffic (https session like https://www.facebook.com) is sent directly to Internet, I receive the 'Application Blocked page' in the browser.

If the traffic goes through the proxy (explicit configuration in the browser), I don't receive the 'Application Blocked page' in the browser.


Is it the default behaviour ?

How can I change this ??


Regards,


HA


1 accepted solution

Accepted Solutions

L4 Transporter

This is expected behavior.

When configuring file blocking or URL filtering profiles for a policy and the action Continue is configured to prompt users before downloading files or accessing certain URLs, the continue page will not appear when accessing HTTPS sites. This will occurs if the firewall is configured with SSL decryption and the user’s browser is using a proxy server. The only workaround for this issue at this time is to disable proxy on the browser. The browsers that were tested for this issue include Internet Explorer versions 7 and 8, other browsers may also have this issue.

I'll work on a getting this in our KB.

Thanks,

Dominic

PaloAlto Networks

View solution in original post

4 REPLIES 4

L6 Presenter

Hi HA...Are you matching the application & action=deny, or are you using URL filtering to match the domain and block?

Hello,

I match at the application layer.

Basically, at the end of the rule base, I have a rule which block everything.

In the traffic log file, I clearly see 'facebook-base', action : deny.

Regards,

HA

L4 Transporter

This is expected behavior.

When configuring file blocking or URL filtering profiles for a policy and the action Continue is configured to prompt users before downloading files or accessing certain URLs, the continue page will not appear when accessing HTTPS sites. This will occurs if the firewall is configured with SSL decryption and the user’s browser is using a proxy server. The only workaround for this issue at this time is to disable proxy on the browser. The browsers that were tested for this issue include Internet Explorer versions 7 and 8, other browsers may also have this issue.

I'll work on a getting this in our KB.

Thanks,

Dominic

PaloAlto Networks

Hello Dominic,

First, thanks for your help.

Any plan to change this behaviour in the future ??

Regards,

Hedi

  • 1 accepted solution
  • 4013 Views
  • 4 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!