Error "An instance of GlobalProtect is already present on the system."

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error "An instance of GlobalProtect is already present on the system."

L0 Member



1. I unstalled the GlobalProtect for Windows 7(64 bits) then tried to install ProductVersion = 3.1.5.


But I encountered the same error as follows over and over even after I followed up the comment in the link(, which did not help anything.


An instance of GlobalProtect is already present on the system. Uninstall the current version before attempting to install the new version of GlobalProtect.

=== Logging stopped: 2017-07-07 10:18:01 ===




2. I checked the entries in "regedit" then deleted any related GlobaProtect even directory path after uninstall as the link above explained, but the new installation is having problem with the same issue above.


3. Here is what I tried to troubleshoot by the command line(msiexec) at Windows 7.
$ msiexec /i GlobalProtect64_2017_06_14.msi /l*vx debug.log

4. And the following is the messages in the debug.log
=== Logging stopped: 2017-07-07 13:08:04 ===
MSI (c) (84:58) [13:08:04:494]: Note: 1: 1708
MSI (c) (84:58) [13:08:04:494]: Note: 1: 2262 2: Error 3: -2147287038
MSI (c) (84:58) [13:08:04:494]: Note: 1: 2262 2: Error 3: -2147287038
MSI (c) (84:58) [13:08:04:494]: Product: GlobalProtect -- Installation failed.
MSI (c) (84:58) [13:08:04:494]: Windows Installer installed the product. Product Name: GlobalProtect. Product Version: 3.1.5. Product Language: 1033. Manufacturer: Palo Alto Networks. Installation success or error status: 1603.
MSI (c) (84:58) [13:08:04:495]: Grabbed execution mutex.
MSI (c) (84:58) [13:08:04:495]: Cleaning up uninstalled install packages, if any exist
MSI (c) (84:58) [13:08:04:497]: MainEngineThread is returning 1603
=== Verbose logging stopped: 2017-07-07 13:08:04 ===

Can anyone please advise me of how to solve this problem?


Hi @Sydney.Jin


I recommend that you remove any registry keys related to GlobalProtect, and then reboot the machine (In case you haven't done that already). Then attempt the installation one more time.


I hope this helps

L2 Linker

If @acc6d0b3610eec313831f7900fdbd235 suggestion doesn't work, you could also try reinstalling the previous version, uninstall it again and then attempt to install v3.1.5.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!