GlobalProtect App Dynamic Configuration misses information for 'show-system-tray-notifications'


Changes to the LIVEcommunity experience are coming soon... Here's what you need to know.

L1 Bithead

Problems came with the update from 8.0.x to 8.1.13.

This workaround worked for me today.


L0 Member

Just a bit more insight into this issue.  3 portals were showing the message so I wanted to see what change the recommended solution in this thread was making.

Portal 1 - Went to agent settings, clicked ok and noticed the commit link went blue.

It appears that the xml was not in the correct order and this "OK" click rearranges it.





L1 Bithead

I had the same issue come up today, and the previous fix worked.  just going in and opening each agent configuration and clicking ok for all of them and then comitting fixed it. 


L2 Linker

(4/4/2020) Beginning with Applications and Threats content release version 8252, the dynamic configuration for System Tray Notification in the GlobalProtect app is removed (this option was deprecated starting in GlobalProtect app 4.1). You should expect to see a commit warning message ("GlobalProtect App Dynamic Configuration misses information for 'show-system-tray-notifications'") after you update to this or a later content release version. To permanently dismiss this warning message when it first appears, run the following CLI command in configuration mode:
delete global-protect global-protect-portal "<portal name>" client-config configs "<agent-config-name>" gp-app-config config show-system-tray-notifications


L0 Member

Did not work for us.  We are on 8.1.13.  3020 HA pair.



L0 Member

Just to qualify, what specifically worked for me, was the following;

Open each Portal Configuration>Network tab>GlobalProtect>Portals>click on each Porta>click on Agent>open the Agent listed under Configs>from the Configs window click on OK, then click OK to close the Portal Configuration screen>Commit changes to device.

Hope this helps someone.

L3 Networker

This solution seemed to do the trick for me on the 220, will try this on the 5050s as well. thanks!

L1 Bithead

We were able to resolve this by performing a content update and then committing.

L0 Member

Do not worry, you can follow the link below for the solution:


Yes, the solution is that simple 



Cyber Elite

Seems PA have this KB now for  how to fix this issue from CLI and GUI



Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!